summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-01-31 11:55:40 -0800
committerMatt Turner <mattst88@gentoo.org>2022-01-31 11:55:40 -0800
commit288839b7e7b8b7f446fb827f3aa442d53dcd47d2 (patch)
treefd6d7d1b7bd1d7342aac196aff0d902ee8581b5a /app-accessibility
parentapp-admin/selint: bump 1.2.1 (diff)
downloadgentoo-288839b7e7b8b7f446fb827f3aa442d53dcd47d2.tar.gz
gentoo-288839b7e7b8b7f446fb827f3aa442d53dcd47d2.tar.bz2
gentoo-288839b7e7b8b7f446fb827f3aa442d53dcd47d2.zip
app-accessibility/orca: Version bump to 41.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/orca/Manifest1
-rw-r--r--app-accessibility/orca/orca-41.2.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/app-accessibility/orca/Manifest b/app-accessibility/orca/Manifest
index a6c7a1e971ce..c2deb1784c97 100644
--- a/app-accessibility/orca/Manifest
+++ b/app-accessibility/orca/Manifest
@@ -1,3 +1,4 @@
DIST orca-40.0.tar.xz 3603368 BLAKE2B 3ac99f32ee496004e568ce61d5862591556bedfd8dc7ef1b707b62b120f1349ae38bbd427b0d3cc67c7be7334bcc46b067ee44a45c51bcdbdf15ee78c0243f64 SHA512 16e15b1cb4b5a2a3d14ddf9e9277e6b0c65e2ab0a7370fd8bfb830bee9d208ef6b5b3d0c19cc2ff6107f3b0cd41e8ae00881033645f7a309ca3ce65aebd73a1b
DIST orca-40.1.tar.xz 3603308 BLAKE2B e934e54d598a70ec22014a0749ce8b6cc2cb8d27c9fbb8d2488b0d088ebe175dd21a96e51ccb9eccba0254bf4664bc36796cdd2c965d1721562cf1a83d0e3fc7 SHA512 4e3bec3151abe81bb7d07717dba94e7a998ec269af430e2a5ef999b6c39606066df7f4161861a0e7c019626d9c609f4de154814d9af3b60e6bc8a1565e0fa075
DIST orca-41.1.tar.xz 3635644 BLAKE2B 8951111e0eb6e89709c4fbf98ab92cc503995c8dddfe150b925ce18f638377feb6786419bba394cd8652f4d39254f64d179a223b48c0faef8fa20b070fcbbe11 SHA512 4f6534025d70231b6c43cfe1f6d8d5c8f33b4727a0bc83417e65c564364a63a64d44d61be2786166814dbd7b1b7bad38f69b008ce119ca45b0fc9be0f512549b
+DIST orca-41.2.tar.xz 3637836 BLAKE2B bebe1d6e37b88f8e1c97c2ee2a599185c2c14d88fc7d12805bb5a7623b1323ad8688cb846b6e733ef02d58390eb390d1dcd2150a0ed50c8109a7468d62f525c2 SHA512 a2d208193aaac48bf12ca22732b338cdcb5299edc7e7b5c75c88f8dee6ad69762287dbb36c25661c08f904b3848a2ca0e60f2d7153e41594944fab509ff3ef07
diff --git a/app-accessibility/orca/orca-41.2.ebuild b/app-accessibility/orca/orca-41.2.ebuild
new file mode 100644
index 000000000000..ce740f046a7c
--- /dev/null
+++ b/app-accessibility/orca/orca-41.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Extensible screen reader that provides access to the desktop"
+HOMEPAGE="https://wiki.gnome.org/Projects/Orca"
+
+LICENSE="LGPL-2.1+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="+braille"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=app-accessibility/at-spi2-atk-2.34:2
+ >=app-accessibility/at-spi2-core-2.36:2[introspection]
+ >=dev-libs/atk-2.36
+ >=dev-libs/glib-2.28:2
+ media-libs/gstreamer:1.0[introspection]
+ >=x11-libs/gtk+-3.6.2:3[introspection]
+ $(python_gen_cond_dep '
+ dev-python/gst-python:1.0[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.18:3[${PYTHON_USEDEP}]
+ ')
+ braille? (
+ $(python_gen_cond_dep '
+ >=app-accessibility/brltty-5.0-r3[python,${PYTHON_USEDEP}]
+ dev-libs/liblouis[python,${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ dev-libs/atk[introspection]
+ $(python_gen_cond_dep '
+ >=app-accessibility/speech-dispatcher-0.8[python,${PYTHON_USEDEP}]
+ >=dev-python/pyatspi-2.36[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ ')
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+"
+BDEPEND="
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+# app-text/yelp-tools
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_with braille liblouis)
+}
+
+src_install() {
+ gnome2_src_install
+ python_optimize
+}