summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-04-03 12:31:38 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-04-03 13:13:16 -0500
commit60944549fb37913447bc1bb09717a28d9f53444f (patch)
tree0685077ec99c083cebcf859fcbdadd7e451453ab /app-accessibility
parentsys-cluster/k3s: fix init script bashisms (diff)
downloadgentoo-60944549fb37913447bc1bb09717a28d9f53444f.tar.gz
gentoo-60944549fb37913447bc1bb09717a28d9f53444f.tar.bz2
gentoo-60944549fb37913447bc1bb09717a28d9f53444f.zip
app-accessibility/espeak-ng: add 1.51
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/espeak-ng/Manifest1
-rw-r--r--app-accessibility/espeak-ng/espeak-ng-1.51.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/app-accessibility/espeak-ng/Manifest b/app-accessibility/espeak-ng/Manifest
index ca6c1169c145..c145ee48ff57 100644
--- a/app-accessibility/espeak-ng/Manifest
+++ b/app-accessibility/espeak-ng/Manifest
@@ -1,2 +1,3 @@
DIST espeak-ng-1.50-ieee80.patch.xz 8128 BLAKE2B f9ae3b64d52f18b0dd4bb1ff1832d89fc22c319bccf3f7ada61628569857fded15a426703d035737b829fc8580707876ad09527380890f73df919740b40aa046 SHA512 4183fd13c902bdda27ac7e86fb4e4573ce85ca015aaea757aed27a869e4067a58c99b8f4d3e289710d1359d4fa289c2a4e6d5803845cd454c3dc59f79f4e2e80
DIST espeak-ng-1.50.tar.gz 13665536 BLAKE2B c64c2a474374d4b6fe13bf3a99f5dfb661923c13ebd6c0bc323e7f26d9d90945c7075cc5c8f4b51e5db3303632c8c9daca7a65a1883e09d7c3faf63dd725ea3f SHA512 297dd80a6cdae3e2b8acf6823475220ce89d6a5fb68ea303156ad52cb3e7388049b6921759d4ed4e3d2e2ebd19bf931259e454f74a2ac0b7ecf4ce56c1d60c0c
+DIST espeak-ng-1.51.tar.gz 14260788 BLAKE2B 230e8860247bdd44a26ba7281fadb7486e7fff90de229c71fb883693badfc141d5ad883769d6cead150f43560a5c47152cada4fcb5a28c0b0384dacaad2c9d09 SHA512 6c29275706d21de2d5fa393702d2f173fc05d2ce4e2f46f3bf9a2742b0a8f294177663df0d079188e31cc2541f2c21a64e09e8afffe95befab667a4d00429fd2
diff --git a/app-accessibility/espeak-ng/espeak-ng-1.51.ebuild b/app-accessibility/espeak-ng/espeak-ng-1.51.ebuild
new file mode 100644
index 000000000000..345d810491c0
--- /dev/null
+++ b/app-accessibility/espeak-ng/espeak-ng-1.51.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Software speech synthesizer for English, and some other languages"
+HOMEPAGE="https://github.com/espeak-ng/espeak-ng"
+SRC_URI="https://github.com/espeak-ng/espeak-ng/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+ unicode"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+async +klatt l10n_ru l10n_zh man mbrola +sound"
+
+COMMON_DEPEND="
+ !app-accessibility/espeak
+ mbrola? ( app-accessibility/mbrola )
+ sound? ( media-libs/pcaudiolib )
+"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}
+ sound? ( media-sound/sox )
+"
+BDEPEND="
+ virtual/pkgconfig
+ man? ( || ( app-text/ronn-ng app-text/ronn ) )
+"
+
+DOCS=( CHANGELOG.md README.md docs )
+
+src_prepare() {
+ default
+
+ # disable failing tests
+ rm tests/{language-pronunciation,translate}.test || die
+ sed -i \
+ -e "/language-pronunciation.check/d" \
+ -e "/translate.check/d" \
+ Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local econf_args
+ econf_args=(
+ $(use_with async)
+ $(use_with klatt)
+ $(use_with l10n_ru extdict-ru)
+ $(use_with l10n_zh extdict-cmn)
+ $(use_with l10n_zh extdict-yue)
+ $(use_with mbrola)
+ $(use_with sound pcaudiolib)
+ --without-libfuzzer
+ --without-speechplayer
+ --without-sonic
+ --disable-rpath
+ --disable-static
+ )
+ econf "${econf_args[@]}"
+}
+
+src_compile() {
+ emake
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ emake DESTDIR="${D}" VIMDIR=/usr/share/vim/vimfiles install -j1
+ find "${ED}" -name '*.la' -delete || die
+}