summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-06 14:56:53 +0100
committerSam James <sam@gentoo.org>2023-05-06 15:17:06 +0100
commit66e2bdfde3832e2a163613bba148ebdb6bae472d (patch)
tree77e32cfe5386a81a3f550e213714116fac7a5878 /app-accessibility
parentdev-libs/libclc: 16.x live is now 16.0.4 (diff)
downloadgentoo-66e2bdfde3832e2a163613bba148ebdb6bae472d.tar.gz
gentoo-66e2bdfde3832e2a163613bba148ebdb6bae472d.tar.bz2
gentoo-66e2bdfde3832e2a163613bba148ebdb6bae472d.zip
app-accessibility/speech-dispatcher: make USE=espeak enable app-accessibility/espeak-ng instead
'espeak' is the standard USE flag for espeak so having USE=espeak mean app-accessibility/espeak (which is deprecated and can't be installed a lot of the time because other packages rightly now hard-depend on app-accessibility/espeak-ng) leads to confusing/poor UX. Finally drop app-accessibility/espeak support entirely in favour of app-accessibility/espeak-ng and make USE=espeak enable espeak-ng. Bug: https://bugs.gentoo.org/877221 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/speech-dispatcher/metadata.xml3
-rw-r--r--app-accessibility/speech-dispatcher/speech-dispatcher-0.11.4-r1.ebuild (renamed from app-accessibility/speech-dispatcher/speech-dispatcher-0.11.4.ebuild)11
2 files changed, 6 insertions, 8 deletions
diff --git a/app-accessibility/speech-dispatcher/metadata.xml b/app-accessibility/speech-dispatcher/metadata.xml
index 4df386ee0a85..506de2e0ba7d 100644
--- a/app-accessibility/speech-dispatcher/metadata.xml
+++ b/app-accessibility/speech-dispatcher/metadata.xml
@@ -13,8 +13,7 @@
<name>Gentoo Sound project</name>
</maintainer>
<use>
- <flag name="espeak">Adds support for espeak speech engine</flag>
- <flag name="espeak-ng">Adds support for espeak-ng speech engine</flag>
+ <flag name="espeak">Adds support for espeak-ng speech engine</flag>
<flag name="flite">Adds support for flite speech engine</flag>
</use>
<upstream>
diff --git a/app-accessibility/speech-dispatcher/speech-dispatcher-0.11.4.ebuild b/app-accessibility/speech-dispatcher/speech-dispatcher-0.11.4-r1.ebuild
index 95fa8f646009..1b0b5acf3017 100644
--- a/app-accessibility/speech-dispatcher/speech-dispatcher-0.11.4.ebuild
+++ b/app-accessibility/speech-dispatcher/speech-dispatcher-0.11.4-r1.ebuild
@@ -14,7 +14,7 @@ SRC_URI="https://github.com/brailcom/speechd/releases/download/${PV}/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ppc ppc64 ~riscv sparc x86"
-IUSE="alsa ao espeak +espeak-ng flite nas pulseaudio python"
+IUSE="alsa ao +espeak flite nas pulseaudio python"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
@@ -24,8 +24,7 @@ DEPEND="python? ( ${PYTHON_DEPS} )
>=media-libs/libsndfile-1.0.2
alsa? ( media-libs/alsa-lib )
ao? ( media-libs/libao )
- espeak? ( app-accessibility/espeak )
- espeak-ng? ( app-accessibility/espeak-ng )
+ espeak? ( app-accessibility/espeak-ng )
flite? ( app-accessibility/flite )
nas? ( media-libs/nas )
pulseaudio? ( media-sound/pulseaudio )"
@@ -59,10 +58,10 @@ src_configure() {
--with-kali=no
--with-pico=no
--with-voxin=no
+ --with-espeak=no
$(use_with alsa)
$(use_with ao libao)
- $(use_with espeak)
- $(use_with espeak-ng)
+ $(use_with espeak espeak-ng)
$(use_with flite)
$(use_with nas)
$(use_with pulseaudio pulse)
@@ -109,7 +108,7 @@ src_install() {
pkg_postinst() {
local editconfig="n"
- if ! use espeak-ng; then
+ if ! use espeak; then
ewarn "You have disabled espeak-ng, which is speech-dispatcher's"
ewarn "default speech synthesizer."
ewarn