summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2017-08-06 17:41:08 +0200
committerAmy Liffey <amynka@gentoo.org>2017-08-06 17:42:18 +0200
commit9b2de194de0bc01d410ff9d3619d03ac53eb8d2b (patch)
treed2860ed3a270dab983b5143ef043f1b0cdf846f9 /app-admin/fetchlog/fetchlog-1.4-r1.ebuild
parentsys-devel/gcc: 4.9.4-r1, actually apply 1.1 patchset. (diff)
downloadgentoo-9b2de194de0bc01d410ff9d3619d03ac53eb8d2b.tar.gz
gentoo-9b2de194de0bc01d410ff9d3619d03ac53eb8d2b.tar.bz2
gentoo-9b2de194de0bc01d410ff9d3619d03ac53eb8d2b.zip
app-admin/fetchlog: eapi bump to 6
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-admin/fetchlog/fetchlog-1.4-r1.ebuild')
-rw-r--r--app-admin/fetchlog/fetchlog-1.4-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-admin/fetchlog/fetchlog-1.4-r1.ebuild b/app-admin/fetchlog/fetchlog-1.4-r1.ebuild
new file mode 100644
index 000000000000..0893accd6e63
--- /dev/null
+++ b/app-admin/fetchlog/fetchlog-1.4-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Displays the last new messages of a logfile"
+HOMEPAGE="http://fetchlog.sourceforge.net/"
+SRC_URI="mirror://sourceforge/fetchlog/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~ppc64"
+
+IUSE="snmp"
+
+RDEPEND="snmp? (
+ >=dev-perl/Net-SNMP-4.0.1-r2
+ >=net-analyzer/net-snmp-5.0.6
+ )"
+
+pkg_preinst() {
+ elog
+ elog "This utility can be used together with Nagios"
+ elog "To make use of these features you need to"
+ elog "install net-analyzer/nagios."
+ elog "This feature depends on SNMP, so make use you"
+ elog "have 'snmp' in your USE flags"
+ elog
+}
+
+src_compile() {
+ # Links the .c file straight to the binary
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} ${LDFLAGS}"
+}
+
+src_install() {
+ dodoc CHANGES README*
+ dodoc *cfg*
+ dobin fetchlog
+ doman fetchlog.1
+}