summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <tmozes@sygic.com>2019-03-05 05:22:47 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-03-05 15:57:47 +0100
commit300ff8928116d3b1d53b5abd70b37c1e1ca3aa5d (patch)
tree7031c060b72fb0e1b987720f7b09497ddb475f7b /app-admin/filebeat/filebeat-6.4.3.ebuild
parentmedia-sound/pragha: Bump to 1.3.4 (stable branch) (diff)
downloadgentoo-300ff8928116d3b1d53b5abd70b37c1e1ca3aa5d.tar.gz
gentoo-300ff8928116d3b1d53b5abd70b37c1e1ca3aa5d.tar.bz2
gentoo-300ff8928116d3b1d53b5abd70b37c1e1ca3aa5d.zip
app-admin/filebeat: revert stable version drop
This reverts commit 75f6acc429f35dfd5f9bc60711a399020ee0fea1. Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/11262 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'app-admin/filebeat/filebeat-6.4.3.ebuild')
-rw-r--r--app-admin/filebeat/filebeat-6.4.3.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/app-admin/filebeat/filebeat-6.4.3.ebuild b/app-admin/filebeat/filebeat-6.4.3.ebuild
new file mode 100644
index 000000000000..8a81429845c7
--- /dev/null
+++ b/app-admin/filebeat/filebeat-6.4.3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Lightweight log shipper for Logstash and Elasticsearch"
+HOMEPAGE="https://www.elastic.co/products/beats"
+SRC_URI="https://github.com/elastic/beats/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+
+DEPEND=">=dev-lang/go-1.10.3"
+RDEPEND="!app-admin/filebeat-bin"
+
+# Do not complain about CFLAGS etc since go projects do not use them.
+QA_FLAGS_IGNORED='.*'
+
+S="${WORKDIR}/src/github.com/elastic/beats"
+
+src_unpack() {
+ mkdir -p "${S%/*}" || die
+ default
+ mv beats-${PV} "${S}" || die
+}
+
+src_prepare() {
+ default
+
+ # avoid Elastic license
+ rm -r x-pack || die
+
+ # use ${PV} instead of git commit id
+ sed -i "s/\(COMMIT_ID=\).*/\1${PV}/g" "${S}/libbeat/scripts/Makefile" || die
+}
+
+src_compile() {
+ GOPATH="${WORKDIR}" emake -C "${S}/filebeat"
+}
+
+src_install() {
+ keepdir /var/{lib,log}/${PN}
+
+ fperms 0750 /var/{lib,log}/${PN}
+
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+ newinitd "${FILESDIR}/${PN}.initd.1" ${PN}
+
+ docinto examples
+ dodoc ${PN}/{filebeat.yml,filebeat.reference.yml}
+
+ dobin filebeat/filebeat
+}
+
+pkg_postinst() {
+ if [[ -n "${REPLACING_VERSIONS}" ]]; then
+ elog "Please read the migration guide at:"
+ elog "https://www.elastic.co/guide/en/beats/libbeat/$(ver_cut 1-2)/upgrading.html"
+ elog ""
+ fi
+
+ elog "Example configurations:"
+ elog "${EROOT}/usr/share/doc/${PF}/examples"
+}