summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/longrun/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/longrun/files')
-rw-r--r--app-admin/longrun/files/0.9-makefile_cflags.patch14
-rw-r--r--app-admin/longrun/files/0.9-replace-loff_t.patch35
2 files changed, 49 insertions, 0 deletions
diff --git a/app-admin/longrun/files/0.9-makefile_cflags.patch b/app-admin/longrun/files/0.9-makefile_cflags.patch
new file mode 100644
index 000000000000..a15229177881
--- /dev/null
+++ b/app-admin/longrun/files/0.9-makefile_cflags.patch
@@ -0,0 +1,14 @@
+Common subdirectories: longrun.old/debian and longrun/debian
+diff -u longrun.old/Makefile longrun/Makefile
+--- longrun.old/Makefile 2005-08-12 22:36:14.186390784 +0300
++++ longrun/Makefile 2005-08-12 22:37:36.157929216 +0300
+@@ -3,7 +3,7 @@
+ all: longrun README stamp-po
+
+ longrun: longrun.c
+- gcc -DLOCALEDIR=\"$(LOCALEDIR)\" -g -O2 -W -Wall -o longrun longrun.c
++ $(CC) $(CFLAGS) $(LDFLAGS) -DLOCALEDIR=\"$(LOCALEDIR)\" -W -Wall -o longrun longrun.c
+
+ README: longrun.1
+ groff -Tascii -man longrun.1 | col -bx > README
+Common subdirectories: longrun.old/po and longrun/po
diff --git a/app-admin/longrun/files/0.9-replace-loff_t.patch b/app-admin/longrun/files/0.9-replace-loff_t.patch
new file mode 100644
index 000000000000..589c0947b155
--- /dev/null
+++ b/app-admin/longrun/files/0.9-replace-loff_t.patch
@@ -0,0 +1,35 @@
+Use off_t instead of loff_t. Both pread() and pwrite() take
+off_t not loff_t types. This breaks the build on musl. See
+
+https://bugs.gentoo.org/show_bug.cgi?id=541694
+
+diff -Naur longrun.orig/longrun.c longrun/longrun.c
+--- longrun.orig/longrun.c 2015-03-07 19:05:19.166652462 +0000
++++ longrun/longrun.c 2015-03-07 19:06:05.419651899 +0000
+@@ -181,7 +181,7 @@
+ }
+
+ /* note: if an output is NULL, then don't set it */
+-void read_msr(loff_t address, int *lower, int *upper)
++void read_msr(off_t address, int *lower, int *upper)
+ {
+ uint32_t data[2];
+
+@@ -193,7 +193,7 @@
+ if (upper) *upper = data[1];
+ }
+
+-void write_msr(loff_t address, int lower, int upper)
++void write_msr(off_t address, int lower, int upper)
+ {
+ uint32_t data[2];
+
+@@ -206,7 +206,7 @@
+ }
+
+ /* note: if an output is NULL, then don't set it */
+-void read_cpuid(loff_t address, int *eax, int *ebx, int *ecx, int *edx)
++void read_cpuid(off_t address, int *eax, int *ebx, int *ecx, int *edx)
+ {
+ uint32_t data[4];
+