summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/longrun/files')
-rw-r--r--app-admin/longrun/files/0.9-makefile_cflags.patch14
-rw-r--r--app-admin/longrun/files/0.9-replace-loff_t.patch35
2 files changed, 49 insertions, 0 deletions
diff --git a/app-admin/longrun/files/0.9-makefile_cflags.patch b/app-admin/longrun/files/0.9-makefile_cflags.patch
new file mode 100644
index 000000000000..a15229177881
--- /dev/null
+++ b/app-admin/longrun/files/0.9-makefile_cflags.patch
@@ -0,0 +1,14 @@
+Common subdirectories: longrun.old/debian and longrun/debian
+diff -u longrun.old/Makefile longrun/Makefile
+--- longrun.old/Makefile 2005-08-12 22:36:14.186390784 +0300
++++ longrun/Makefile 2005-08-12 22:37:36.157929216 +0300
+@@ -3,7 +3,7 @@
+ all: longrun README stamp-po
+
+ longrun: longrun.c
+- gcc -DLOCALEDIR=\"$(LOCALEDIR)\" -g -O2 -W -Wall -o longrun longrun.c
++ $(CC) $(CFLAGS) $(LDFLAGS) -DLOCALEDIR=\"$(LOCALEDIR)\" -W -Wall -o longrun longrun.c
+
+ README: longrun.1
+ groff -Tascii -man longrun.1 | col -bx > README
+Common subdirectories: longrun.old/po and longrun/po
diff --git a/app-admin/longrun/files/0.9-replace-loff_t.patch b/app-admin/longrun/files/0.9-replace-loff_t.patch
new file mode 100644
index 000000000000..589c0947b155
--- /dev/null
+++ b/app-admin/longrun/files/0.9-replace-loff_t.patch
@@ -0,0 +1,35 @@
+Use off_t instead of loff_t. Both pread() and pwrite() take
+off_t not loff_t types. This breaks the build on musl. See
+
+https://bugs.gentoo.org/show_bug.cgi?id=541694
+
+diff -Naur longrun.orig/longrun.c longrun/longrun.c
+--- longrun.orig/longrun.c 2015-03-07 19:05:19.166652462 +0000
++++ longrun/longrun.c 2015-03-07 19:06:05.419651899 +0000
+@@ -181,7 +181,7 @@
+ }
+
+ /* note: if an output is NULL, then don't set it */
+-void read_msr(loff_t address, int *lower, int *upper)
++void read_msr(off_t address, int *lower, int *upper)
+ {
+ uint32_t data[2];
+
+@@ -193,7 +193,7 @@
+ if (upper) *upper = data[1];
+ }
+
+-void write_msr(loff_t address, int lower, int upper)
++void write_msr(off_t address, int lower, int upper)
+ {
+ uint32_t data[2];
+
+@@ -206,7 +206,7 @@
+ }
+
+ /* note: if an output is NULL, then don't set it */
+-void read_cpuid(loff_t address, int *eax, int *ebx, int *ecx, int *edx)
++void read_cpuid(off_t address, int *eax, int *ebx, int *ecx, int *edx)
+ {
+ uint32_t data[4];
+