summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-02-04 08:41:43 +0100
committerMichał Górny <mgorny@gentoo.org>2018-02-04 09:44:29 +0100
commit75ca4770f0093e0474200b575b5e62636d984904 (patch)
tree1b95d28944b0fb349f6f84943add11ebe120a955 /app-admin/systemrescuecd-x86/systemrescuecd-x86-5.2.0.ebuild
parentmedia-sound/grip: Removed old. (diff)
downloadgentoo-75ca4770f0093e0474200b575b5e62636d984904.tar.gz
gentoo-75ca4770f0093e0474200b575b5e62636d984904.tar.bz2
gentoo-75ca4770f0093e0474200b575b5e62636d984904.zip
app-admin/systemrescuecd-x86: Bump to 5.2.0
Diffstat (limited to 'app-admin/systemrescuecd-x86/systemrescuecd-x86-5.2.0.ebuild')
-rw-r--r--app-admin/systemrescuecd-x86/systemrescuecd-x86-5.2.0.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/app-admin/systemrescuecd-x86/systemrescuecd-x86-5.2.0.ebuild b/app-admin/systemrescuecd-x86/systemrescuecd-x86-5.2.0.ebuild
new file mode 100644
index 000000000000..7bfc35a7dd27
--- /dev/null
+++ b/app-admin/systemrescuecd-x86/systemrescuecd-x86-5.2.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="The .iso image of SystemRescueCD rescue disk, x86 (+ amd64) variant"
+HOMEPAGE="http://www.sysresccd.org/"
+# Large ISO mirroring explicitly approved by infra in bug #588766
+SRC_URI="mirror://sourceforge/systemrescuecd/sysresccd-${PN#*-}/${PV}/${P}.iso"
+
+LICENSE="GPL-2"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+isohybrid"
+
+DEPEND="isohybrid? ( >=sys-boot/syslinux-4 )"
+
+S=${WORKDIR}
+
+src_install() {
+ insinto "/usr/share/${PN%-*}"
+ doins "${DISTDIR}/${P}.iso"
+
+ if use isohybrid; then
+ set -- isohybrid -u "${ED}usr/share/${PN%-*}/${P}.iso"
+ echo "${@}"
+ "${@}" || die "${*} failed"
+ fi
+}
+
+pkg_postinst() {
+ local f=${EROOT%/}/usr/share/${PN%-*}/${PN}-newest.iso
+
+ # no version newer than ours? we're the newest!
+ if ! has_version ">${CATEGORY}/${PF}"; then
+ ln -f -s -v "${P}.iso" "${f}" || die
+ fi
+}
+
+pkg_postrm() {
+ local f=${EROOT%/}/usr/share/${PN%-*}/${PN}-newest.iso
+
+ # if there is no version newer than ours installed
+ if ! has_version ">${CATEGORY}/${PF}"; then
+ # and we are truly and completely uninstalled...
+ if [[ ! ${REPLACED_BY_VERSION} ]]; then
+ # then find an older version to set the symlink to
+ local newest_version=$(best_version "<${CATEGORY}/${PF}")
+
+ if [[ ${newest_version} ]]; then
+ # update the symlink
+ ln -f -s -v "${newest_version%-r*}.iso" "${f}" || die
+ else
+ # last version removed? clean up the symlink
+ rm -v "${f}" || die
+ # and the parent directory
+ rmdir "${f%/*}" || die
+ fi
+ fi
+ fi
+}