summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-07-10 12:38:27 +0200
committerDavid Seifert <soap@gentoo.org>2022-07-10 12:38:27 +0200
commit871c4217af48b7a615fd92cfbcf15ae5e5984928 (patch)
tree3570ac6953c12fd3f41fb1d5a7e18c28bfd71c3f /app-arch
parentnet-misc/rclone: 1.59.0 version bump. (diff)
downloadgentoo-871c4217af48b7a615fd92cfbcf15ae5e5984928.tar.gz
gentoo-871c4217af48b7a615fd92cfbcf15ae5e5984928.tar.bz2
gentoo-871c4217af48b7a615fd92cfbcf15ae5e5984928.zip
app-arch/zpaq: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/zpaq/zpaq-7.15-r1.ebuild (renamed from app-arch/zpaq/zpaq-7.15.ebuild)14
1 files changed, 7 insertions, 7 deletions
diff --git a/app-arch/zpaq/zpaq-7.15.ebuild b/app-arch/zpaq/zpaq-7.15-r1.ebuild
index aabf4cdca479..cd79e48be432 100644
--- a/app-arch/zpaq/zpaq-7.15.ebuild
+++ b/app-arch/zpaq/zpaq-7.15-r1.ebuild
@@ -1,14 +1,16 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit flag-o-matic pax-utils toolchain-funcs
-MY_P=${PN}${PV/./}
+MY_P="${PN}${PV/./}"
+
DESCRIPTION="Journaling incremental deduplicating archiving compressor"
HOMEPAGE="http://mattmahoney.net/dc/zpaq.html"
SRC_URI="http://mattmahoney.net/dc/${MY_P}.zip"
+S="${WORKDIR}"
LICENSE="Unlicense"
SLOT="0"
@@ -16,12 +18,10 @@ KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="debug +jit"
# perl for pod2man
-DEPEND="
+BDEPEND="
app-arch/unzip
dev-lang/perl"
-S=${WORKDIR}
-
src_compile() {
use debug || append-cppflags -DNDEBUG
use jit || append-cppflags -DNOJIT
@@ -34,8 +34,8 @@ src_test() {
}
src_install() {
- emake install PREFIX="${ED%/}"/usr
- use jit && pax-mark m "${ED%/}"/usr/bin/zpaq
+ emake install PREFIX="${ED}"/usr
+ use jit && pax-mark m "${ED}"/usr/bin/zpaq
einstalldocs
}