summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-07-02 22:06:58 +0200
committerDavid Seifert <soap@gentoo.org>2022-07-02 22:06:58 +0200
commitf4237237343bf492a60130d7e2e84e8be2f4488f (patch)
tree3ac7dba7ad0d2dd42d606aba7687ab6d4dd4a23f /app-arch
parentapp-arch/lzop: update EAPI 6 -> 8 (diff)
downloadgentoo-f4237237343bf492a60130d7e2e84e8be2f4488f.tar.gz
gentoo-f4237237343bf492a60130d7e2e84e8be2f4488f.tar.bz2
gentoo-f4237237343bf492a60130d7e2e84e8be2f4488f.zip
app-arch/pdv: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/pdv/pdv-1.5.1-r4.ebuild (renamed from app-arch/pdv/pdv-1.5.1-r3.ebuild)47
1 files changed, 24 insertions, 23 deletions
diff --git a/app-arch/pdv/pdv-1.5.1-r3.ebuild b/app-arch/pdv/pdv-1.5.1-r4.ebuild
index 8b712196c4de..b50f939fa91a 100644
--- a/app-arch/pdv/pdv-1.5.1-r3.ebuild
+++ b/app-arch/pdv/pdv-1.5.1-r4.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
inherit autotools toolchain-funcs
DESCRIPTION="build a self-extracting and self-installing binary package"
@@ -11,48 +12,48 @@ SRC_URI="mirror://sourceforge/pdv/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~hppa ppc x86 ~x86-linux ~ppc-macos"
-IUSE="X"
+IUSE="gui"
-DEPEND="
- X? (
+RDEPEND="
+ gui? (
>=x11-libs/motif-2.3:0
>=x11-libs/libX11-1.0.0
>=x11-libs/libXt-1.0.0
- >=x11-libs/libXext-1.0.0 )
-"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- default
+ >=x11-libs/libXext-1.0.0
+ )"
+DEPEND="${RDEPEND}"
+PATCHES=(
# fix a size-of-variable bug
- eapply "${FILESDIR}"/${P}-opt.patch
+ "${FILESDIR}"/${P}-opt.patch
# fix a free-before-use bug
- eapply "${FILESDIR}"/${P}-early-free.patch
+ "${FILESDIR}"/${P}-early-free.patch
# fix a configure script bug
- eapply "${FILESDIR}"/${P}-x-config.patch
+ "${FILESDIR}"/${P}-x-config.patch
# fix default args bug from assuming 'char' is signed
- eapply "${FILESDIR}"/${P}-default-args.patch
+ "${FILESDIR}"/${P}-default-args.patch
# prevent pre-stripped binaries
- eapply "${FILESDIR}"/${P}-no-strip.patch
+ "${FILESDIR}"/${P}-no-strip.patch
+)
+
+src_prepare() {
+ default
# re-build configure script since patch was applied to configure.in
- cd "${S}"/X11
- mv configure.in configure.ac || die
+ cd X11 || die
eautoreconf
- tc-export CC
}
src_configure() {
- local myconf=""
- use X || myconf="--without-x" # configure script is broken, cant use use_with
- econf ${myconf}
+ tc-export CC
+
+ econf $(usev !gui --without-x) # configure script is broken, cant use use_with
}
src_install() {
dobin pdv pdvmkpkg
doman pdv.1 pdvmkpkg.1
- if use X ; then
+ if use gui ; then
dobin X11/xmpdvmkpkg
doman xmpdvmkpkg.1
fi