summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-04-16 18:03:21 +0200
committerMarek Szuba <marecki@gentoo.org>2021-04-16 20:24:28 +0200
commit71b28f813aefc118fdb171e6293a03a95204c00e (patch)
treed19606f06409edd428fdf8398fc04980efdd3fde /app-backup/borgmatic
parentnet-libs/nodejs: bump v14 to 14.16.1 (diff)
downloadgentoo-71b28f813aefc118fdb171e6293a03a95204c00e.tar.gz
gentoo-71b28f813aefc118fdb171e6293a03a95204c00e.tar.bz2
gentoo-71b28f813aefc118fdb171e6293a03a95204c00e.zip
app-backup/borgmatic: bump to 1.5.13
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-backup/borgmatic')
-rw-r--r--app-backup/borgmatic/Manifest1
-rw-r--r--app-backup/borgmatic/borgmatic-1.5.13.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/app-backup/borgmatic/Manifest b/app-backup/borgmatic/Manifest
index 722f91486495..e74bd2d232c6 100644
--- a/app-backup/borgmatic/Manifest
+++ b/app-backup/borgmatic/Manifest
@@ -1 +1,2 @@
DIST borgmatic-1.5.12.tar.gz 72964 BLAKE2B d71537eed019b10c3257d4b068c31aff63919e0cdb068b49c2ed92d2e97d37b8735f30b1225fb453e79372aeab49817e9200770aac4cc0f80c0bac14e84678d1 SHA512 67c7c7683e9fb7dd0321b3db6887212b040596f1d7e767cceeae6fa4cc02bb0a46344befbbc7a33b454a4692b04ae88d9031f71867788a94f771999d885112d5
+DIST borgmatic-1.5.13.tar.gz 72469 BLAKE2B 3a71be201143a96968bb1ea6008b62e11f6ab199f44f38d0d66f31f24827a8f32cc7b8f50cc5d33a8bbd7046e6697afe509525be90dd9519f4c686b8737f64c5 SHA512 60bcbcc825db3f93a423ab8e44e0b0809ff4937d8e41bc56ec6226e4865c3a66fae8b6749d33cdb0692ea9dd07cfff56750ff2feee68c96791b83c9dd5f35433
diff --git a/app-backup/borgmatic/borgmatic-1.5.13.ebuild b/app-backup/borgmatic/borgmatic-1.5.13.ebuild
new file mode 100644
index 000000000000..06c3a588685e
--- /dev/null
+++ b/app-backup/borgmatic/borgmatic-1.5.13.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+
+inherit distutils-r1 systemd
+
+DESCRIPTION="Automatically create, prune and verify backups with borgbackup"
+HOMEPAGE="https://torsion.org/borgmatic/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+
+# Fails due to problems with dev-python/flexmock-0.10.4; see Bug #740128
+RESTRICT="test"
+
+# borg is called as an external tool, hence no pythonic stuff
+RDEPEND="app-backup/borgbackup
+ $(python_gen_cond_dep '
+ dev-python/colorama[${PYTHON_USEDEP}]
+ >=dev-python/pykwalify-1.6.0[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ <dev-python/ruamel-yaml-0.18.0[${PYTHON_USEDEP}]
+ ')"
+#BDEPEND="
+# test? (
+# $(python_gen_cond_dep '
+# dev-python/flexmock[${PYTHON_USEDEP}]
+# ')
+# )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.5.1-systemd_service_bin_path.patch
+ "${FILESDIR}"/${PN}-1.5.1-no_test_coverage.patch
+)
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # Unlike the other two test files in integration/commands, which use the
+ # relevant modules' respective APIs, test_borgmatic.py tries to call the
+ # 'borgmatic' executable - which by the time we execute src_test will
+ # not have been created yet. Adding --install to distutils_enable_tests would
+ # likely take care of this - but between the aforementioned behaviour
+ # inconsistency and the fact the only test run from this file as of version
+ # 1.5.13 is the parsing of contents of 'borgmatic --version', just skip it.
+ rm -f "${S}"/tests/integration/commands/test_borgmatic.py
+}
+
+src_install() {
+ distutils-r1_src_install
+ systemd_dounit sample/systemd/borgmatic.{service,timer}
+ keepdir /etc/borgmatic
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "To generate a sample configuration file, run:"
+ elog " generate-borgmatic-config"
+ fi
+ elog
+ elog "Systemd users wishing to periodically run borgmatic can use the provided timer and service units."
+}