summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-12-02 09:51:42 +0000
committerMarek Szuba <marecki@gentoo.org>2022-12-02 10:00:07 +0000
commitf2082547fbbff36e2d78a830dc41207a8851f7e1 (patch)
treed3e5992a46641c0ea32b743d3870f26aa47c1325 /app-backup/borgmatic
parentnet-analyzer/suricata: add 6.0.9 (diff)
downloadgentoo-f2082547fbbff36e2d78a830dc41207a8851f7e1.tar.gz
gentoo-f2082547fbbff36e2d78a830dc41207a8851f7e1.tar.bz2
gentoo-f2082547fbbff36e2d78a830dc41207a8851f7e1.zip
app-backup/borgmatic: add 1.7.5
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-backup/borgmatic')
-rw-r--r--app-backup/borgmatic/Manifest1
-rw-r--r--app-backup/borgmatic/borgmatic-1.7.5.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/app-backup/borgmatic/Manifest b/app-backup/borgmatic/Manifest
index fb5a67ddc01f..052069337e1d 100644
--- a/app-backup/borgmatic/Manifest
+++ b/app-backup/borgmatic/Manifest
@@ -1,2 +1,3 @@
DIST borgmatic-1.7.2.tar.gz 333772 BLAKE2B fd628e9c77547686d4edf5d1066d3c171575f4d923ebc5205c5eb64f3a960e94c121282e9f4fb02b1291a81011a18dc393c6d13a07f215585459e7a5b55f8107 SHA512 6ec12ec25ae4d0210bb9114795c1ea292d8236f9e68c9425e24ee7b580796504e4c317a3fcf778806a33bbd3db68669beb4ef7a88ec538c1bd432db9a2845b3e
DIST borgmatic-1.7.4.tar.gz 337521 BLAKE2B cbdf22c7428d2bd098a8bec0608c9d2fe41ab945aca4921cf78f72a5b73e2ea562a1e9e37705ada615f830b2655977179beca0f9a9bfa2937cc1cde0c292caed SHA512 bd320cbbb108fa20f7acc9a50fd4404166556a74df0a3631a2beca61de0e50c29e1e102345e6c3759538420040f359ff2f0cefe89b49c2c19250a4c7a27acd54
+DIST borgmatic-1.7.5.tar.gz 338412 BLAKE2B e27fd709070a27c2ddd01fdfe23ef9caeb942c52d756332b4abd6d6cf39724656677a0d142a5392e35e0a0f25958421fe23edf04a252d212d761f48a0c320d9b SHA512 c27a364617e0e8fc1c11adac5375deac4e1663236a545d3fb70280974614d50ffe3821010ed5e4345afa3c3dab5f45c0d3bbfc946f50321601acb56965fd555d
diff --git a/app-backup/borgmatic/borgmatic-1.7.5.ebuild b/app-backup/borgmatic/borgmatic-1.7.5.ebuild
new file mode 100644
index 000000000000..81698a98cd2d
--- /dev/null
+++ b/app-backup/borgmatic/borgmatic-1.7.5.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 systemd
+
+DESCRIPTION="Automatically create, prune and verify backups with borgbackup"
+HOMEPAGE="https://torsion.org/borgmatic/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv"
+
+# borg is called as an external tool, hence no pythonic stuff
+RDEPEND="app-backup/borgbackup
+ $(python_gen_cond_dep '
+ <dev-python/colorama-0.5[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ <dev-python/ruamel-yaml-0.18.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ')"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ >=dev-python/flexmock-0.10.10[${PYTHON_USEDEP}]
+ ')
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.5.1-no_test_coverage.patch
+ "${FILESDIR}"/${PN}-1.7.3-systemd_service_bin_path.patch
+)
+
+# A fragile test whose only purpose is to make sure the NEWS file
+# has been updated for the current version.
+EPYTEST_DESELECT=(
+ tests/integration/commands/test_borgmatic.py::test_borgmatic_version_matches_news_version
+)
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+ systemd_dounit sample/systemd/borgmatic.{service,timer}
+ keepdir /etc/borgmatic
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "To generate a sample configuration file, run:"
+ elog " generate-borgmatic-config"
+ else
+ ewarn "Please note that since version 1.7.0 ${PN} no longer supports old-style command-line action flags like '--create', '--list', etc."
+ ewarn "Make sure all your scripts use actions, e.g. 'create', 'list' and so on"
+ fi
+ elog
+ elog "Systemd users wishing to periodically run borgmatic can use the provided timer and service units."
+}