summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-12-13 02:43:40 -0600
committerTim Harder <radhermit@gentoo.org>2018-12-13 02:48:08 -0600
commitba9195efefe38f5007c2bea862d6658e455090f1 (patch)
tree83465f3693d111820521fd1c08ef26633bc0e7aa /app-backup/bup/files
parentsys-devel/binutils-apple: force gcc-apple usage if necessary (diff)
downloadgentoo-ba9195efefe38f5007c2bea862d6658e455090f1.tar.gz
gentoo-ba9195efefe38f5007c2bea862d6658e455090f1.tar.bz2
gentoo-ba9195efefe38f5007c2bea862d6658e455090f1.zip
app-backup/bup: version bump to 0.29.2
Closes: https://bugs.gentoo.org/661390 Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'app-backup/bup/files')
-rw-r--r--app-backup/bup/files/bup-0.29.2-sitedir.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-backup/bup/files/bup-0.29.2-sitedir.patch b/app-backup/bup/files/bup-0.29.2-sitedir.patch
new file mode 100644
index 000000000000..920b3dc27921
--- /dev/null
+++ b/app-backup/bup/files/bup-0.29.2-sitedir.patch
@@ -0,0 +1,38 @@
+--- bup-0.29.2/Makefile
++++ bup-0.29.2/Makefile
+@@ -25,7 +25,7 @@
+ os := $(shell ($(pf); uname | sed 's/[-_].*//') $(isok))
+ os := $(call shout,$(os),Unable to determine OS)
+
+-CFLAGS := -Wall -O2 -Werror -Wno-unknown-pragmas $(PYINCLUDE) $(CFLAGS)
++CFLAGS := -Wall -Wno-unknown-pragmas $(PYINCLUDE) $(CFLAGS)
+ CFLAGS := -D_FILE_OFFSET_BITS=64 $(CFLAGS)
+ SOEXT:=.so
+
+@@ -93,10 +93,11 @@
+ dest_docdir := $(DESTDIR)$(DOCDIR)
+ dest_bindir := $(DESTDIR)$(BINDIR)
+ dest_libdir := $(DESTDIR)$(LIBDIR)
++dest_sitedir := $(DESTDIR)$(SITEDIR)
+
+ install: all
+- $(INSTALL) -d $(dest_bindir) \
+- $(dest_libdir)/bup $(dest_libdir)/cmd \
++ $(INSTALL) -d $(dest_bindir) $(dest_libdir) \
++ $(dest_sitedir)/bup $(dest_libdir)/cmd \
+ $(dest_libdir)/web $(dest_libdir)/web/static
+ test -z "$(man_roff)" || install -d $(dest_mandir)/man1
+ test -z "$(man_roff)" || $(INSTALL) -m 0644 $(man_roff) $(dest_mandir)/man1
+@@ -109,10 +110,10 @@
+ done
+ $(INSTALL) -pm 0644 \
+ lib/bup/*.py \
+- $(dest_libdir)/bup
++ $(dest_sitedir)/bup
+ $(INSTALL) -pm 0755 \
+ lib/bup/*$(SOEXT) \
+- $(dest_libdir)/bup
++ $(dest_sitedir)/bup
+ $(INSTALL) -pm 0644 \
+ lib/web/static/* \
+ $(dest_libdir)/web/static/