summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Pavljuchenkov (SpiderX) <spiderx@spiderx.dp.ua>2017-02-24 09:32:59 +0200
committerGöktürk Yüksek <gokturk@gentoo.org>2017-04-01 19:56:36 -0400
commit29f1455481e07c0de116380763f79f72342ca786 (patch)
tree32e277a30a268ab337ac7db9ce0aad47bbdc3b55 /app-backup/zbackup/zbackup-9999.ebuild
parentsys-kernel/hardened-sources: version bump to 4.9.20 (diff)
downloadgentoo-29f1455481e07c0de116380763f79f72342ca786.tar.gz
gentoo-29f1455481e07c0de116380763f79f72342ca786.tar.bz2
gentoo-29f1455481e07c0de116380763f79f72342ca786.zip
app-backup/zbackup: new ebuild
zbackup is a globally-deduplicating backup tool, based on the ideas found in rsync. Feed a large .tar into it, and it will store duplicate regions of it only once, then compress and optionally encrypt the result. Feed another .tar file, and it will also re-use any data found in any previous backups. This way only new changes are stored, and as long as the files are not very different, the amount of storage required is very low. Any of the backup files stored previously can be read back in full at any time. Base for ebuild from https://github.com/SpiderX/portage-overlay/tree/master/app-backup/zbackup Gentoo-Bug: https://bugs.gentoo.org/576796 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-backup/zbackup/zbackup-9999.ebuild')
-rw-r--r--app-backup/zbackup/zbackup-9999.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-backup/zbackup/zbackup-9999.ebuild b/app-backup/zbackup/zbackup-9999.ebuild
new file mode 100644
index 000000000000..1d46d49add63
--- /dev/null
+++ b/app-backup/zbackup/zbackup-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils git-r3
+
+DESCRIPTION="A versatile deduplicating backup tool"
+HOMEPAGE="http://zbackup.org/ https://github.com/zbackup/zbackup"
+SRC_URI=""
+EGIT_REPO_URI="git://github.com/${PN}/${PN}.git"
+
+LICENSE="GPL-2+-with-openssl-exception"
+KEYWORDS=""
+SLOT="0"
+IUSE="libressl tartool"
+
+DEPEND="app-arch/lzma
+ dev-libs/lzo:2
+ <dev-libs/protobuf-3:0=
+ sys-libs/libunwind:7
+ sys-libs/zlib
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
+RDEPEND="${DEPEND}"
+
+# Add tartool build
+PATCHES=( "${FILESDIR}/${P}-tartool.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TARTOOL="$(usex tartool)"
+ )
+
+ cmake-utils_src_configure
+}