summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-09-07 17:20:04 +0200
committerDavid Seifert <soap@gentoo.org>2021-09-07 17:20:04 +0200
commit358af1feef453a02aa73ef5c281fe509bcb6ffde (patch)
treeae91268b7926765da7d4b21752c7c68e1140047d /app-crypt/gnupg/gnupg-2.3.2.ebuild
parentapp-crypt/gnupg: remove unused patch (diff)
downloadgentoo-358af1feef453a02aa73ef5c281fe509bcb6ffde.tar.gz
gentoo-358af1feef453a02aa73ef5c281fe509bcb6ffde.tar.bz2
gentoo-358af1feef453a02aa73ef5c281fe509bcb6ffde.zip
app-crypt/gnupg: fix USE=tofu
Bug: https://dev.gnupg.org/T5588 Acked-by: Mikle Kolyada <zlogene@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-crypt/gnupg/gnupg-2.3.2.ebuild')
-rw-r--r--app-crypt/gnupg/gnupg-2.3.2.ebuild17
1 files changed, 6 insertions, 11 deletions
diff --git a/app-crypt/gnupg/gnupg-2.3.2.ebuild b/app-crypt/gnupg/gnupg-2.3.2.ebuild
index 3576669b399e..9e1c1de7266c 100644
--- a/app-crypt/gnupg/gnupg-2.3.2.ebuild
+++ b/app-crypt/gnupg/gnupg-2.3.2.ebuild
@@ -3,18 +3,19 @@
EAPI=8
-inherit autotools flag-o-matic systemd toolchain-funcs
+inherit flag-o-matic systemd toolchain-funcs
MY_P="${P/_/-}"
DESCRIPTION="The GNU Privacy Guard, a GPL OpenPGP implementation"
HOMEPAGE="https://gnupg.org/"
SRC_URI="mirror://gnupg/gnupg/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="bzip2 doc ldap nls readline selinux +smartcard sqlite ssl tofu tools usb user-socket wks-server"
+IUSE="bzip2 doc ldap nls readline selinux +smartcard ssl tofu tools usb user-socket wks-server"
# Existence of executables is checked during configuration.
DEPEND=">=dev-libs/libassuan-2.5.0
@@ -27,7 +28,7 @@ DEPEND=">=dev-libs/libassuan-2.5.0
ldap? ( net-nds/openldap )
readline? ( sys-libs/readline:0= )
smartcard? ( usb? ( virtual/libusb:1 ) )
- sqlite? ( >=dev-db/sqlite-3.27 )
+ tofu? ( >=dev-db/sqlite-3.27 )
ssl? ( >=net-libs/gnutls-3.0:0= )
sys-libs/zlib
"
@@ -42,10 +43,6 @@ BDEPEND="virtual/pkgconfig
doc? ( sys-apps/texinfo )
nls? ( sys-devel/gettext )"
-S="${WORKDIR}/${MY_P}"
-
-REQUIRED_USE="tofu? ( sqlite )"
-
DOCS=(
ChangeLog NEWS README THANKS TODO VERSION
doc/FAQ doc/DETAILS doc/HACKING doc/TRANSLATE doc/OpenPGP doc/KEYSERVER
@@ -53,14 +50,11 @@ DOCS=(
PATCHES=(
"${FILESDIR}/${PN}-2.1.20-gpgscm-Use-shorter-socket-path-lengts-to-improve-tes.patch"
- "${FILESDIR}/${PN}-2.3.0-sqlite_check.patch"
)
src_prepare() {
default
- eautoreconf
-
# Inject SSH_AUTH_SOCK into user's sessions after enabling gpg-agent-ssh.socket in systemctl --user mode,
# idea borrowed from libdbus, see
# https://gitlab.freedesktop.org/dbus/dbus/-/blob/master/bus/systemd-user/dbus.socket.in#L6
@@ -76,9 +70,10 @@ src_configure() {
$(use_enable bzip2)
$(use_enable nls)
$(use_enable smartcard scdaemon)
- $(use_enable sqlite)
$(use_enable ssl gnutls)
$(use_enable tofu)
+ $(use_enable tofu keyboxd)
+ $(use_enable tofu sqlite)
$(use smartcard && use_enable usb ccid-driver || echo '--disable-ccid-driver')
$(use_enable wks-server wks-tools)
$(use_with ldap)