summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2018-12-30 22:51:10 +0200
committerAlon Bar-Lev <alonbl@gentoo.org>2018-12-30 22:58:45 +0200
commit3cd3fa3e139cf893ec5037398b851a519337bcbb (patch)
treef4c6005d7b958de58464c4b3ce2441a1abfa1620 /app-crypt/tpm2-tools/tpm2-tools-3.1.3.ebuild
parentapp-crypt/tpm2-tss: initial add (diff)
downloadgentoo-3cd3fa3e139cf893ec5037398b851a519337bcbb.tar.gz
gentoo-3cd3fa3e139cf893ec5037398b851a519337bcbb.tar.bz2
gentoo-3cd3fa3e139cf893ec5037398b851a519337bcbb.zip
app-crypt/tpm2-tools: initial add
Closes: https://bugs.gentoo.org/show_bug.cgi?id=634304 Thanks: Alex Guzman Thanks: Sebastian Hamann Signed-off-by: Alon Bar-Lev <alonbl@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'app-crypt/tpm2-tools/tpm2-tools-3.1.3.ebuild')
-rw-r--r--app-crypt/tpm2-tools/tpm2-tools-3.1.3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-crypt/tpm2-tools/tpm2-tools-3.1.3.ebuild b/app-crypt/tpm2-tools/tpm2-tools-3.1.3.ebuild
new file mode 100644
index 000000000000..a23c0b4d9a6a
--- /dev/null
+++ b/app-crypt/tpm2-tools/tpm2-tools-3.1.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Tools for the TPM 2.0 TSS"
+HOMEPAGE="https://github.com/tpm2-software/tpm2-tools"
+SRC_URI="https://github.com/tpm2-software/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libressl test"
+
+RDEPEND=">=app-crypt/tpm2-tss-2.0
+ net-misc/curl
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
+DEPEND="${RDEPEND}
+ test? ( dev-util/cmocka )"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --disable-hardening \
+ $(use_enable test unit)
+}