summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-20 06:00:50 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-20 06:00:50 +0100
commit99486c5a54b92ed95263b072ad909b53cb5c8719 (patch)
treec85f4b9d1252194c5b802173df7960e1a4bcb189 /app-doc/python-docs/python-docs-3.10.14.ebuild
parentdev-lang/python: Bump to 3.10.14 (diff)
downloadgentoo-99486c5a54b92ed95263b072ad909b53cb5c8719.tar.gz
gentoo-99486c5a54b92ed95263b072ad909b53cb5c8719.tar.bz2
gentoo-99486c5a54b92ed95263b072ad909b53cb5c8719.zip
app-doc/python-docs: Bump to 3.10.14
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-doc/python-docs/python-docs-3.10.14.ebuild')
-rw-r--r--app-doc/python-docs/python-docs-3.10.14.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-doc/python-docs/python-docs-3.10.14.ebuild b/app-doc/python-docs/python-docs-3.10.14.ebuild
new file mode 100644
index 000000000000..8483ad559ab4
--- /dev/null
+++ b/app-doc/python-docs/python-docs-3.10.14.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="https://www.python.org/doc/"
+SRC_URI="https://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+S="${WORKDIR}/python-${PV}-docs-html"
+
+LICENSE="PSF-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+src_install() {
+ rm -r _sources || die
+ docinto html
+ dodoc -r .
+
+ newenvd - 60python-docs-${SLOT} <<-EOF
+ PYTHONDOCS_${SLOT//./_}="${EPREFIX}/usr/share/doc/${PF}/html/library"
+ EOF
+}