summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-06-09 20:14:13 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-06-09 20:14:30 +0300
commit60d3bd4c1a4a9030e71a7b6825156206946223d4 (patch)
treee92546637a4a35f63b49e1bbbf0c93bac5d6223c /app-editors
parentapp-editors/vscode: add 1.79.0 (diff)
downloadgentoo-60d3bd4c1a4a9030e71a7b6825156206946223d4.tar.gz
gentoo-60d3bd4c1a4a9030e71a7b6825156206946223d4.tar.bz2
gentoo-60d3bd4c1a4a9030e71a7b6825156206946223d4.zip
app-editors/vscodium: add 1.79.0.23159
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vscodium/Manifest3
-rw-r--r--app-editors/vscodium/vscodium-1.79.0.23159.ebuild114
2 files changed, 117 insertions, 0 deletions
diff --git a/app-editors/vscodium/Manifest b/app-editors/vscodium/Manifest
index 5320aa63b7a3..4197b865b433 100644
--- a/app-editors/vscodium/Manifest
+++ b/app-editors/vscodium/Manifest
@@ -4,3 +4,6 @@ DIST vscodium-1.77.3.23102-arm64.tar.gz 111829469 BLAKE2B 1bd2e4f68db9c641a9313c
DIST vscodium-1.78.2.23132-amd64.tar.gz 119476104 BLAKE2B f1a007c72a377dd8f9c1d1cf9c3c38bbb32d28c94305e0445fa4a94f62bd3a32e5122d881f485ebf63958e8183cbc01df96efe1e98078d065b3e4205b1bf8025 SHA512 b4432b6a47be23af8b36359867de6b84b207c2d65817ba30cda33a3b983174bf9c5a06e44a628fbd4764ad054b441fae77a757b099ab808ca7090efad5a189ea
DIST vscodium-1.78.2.23132-arm.tar.gz 108208589 BLAKE2B 4f3ca84b8fe87907c21f0befa59969e9cb243f52ffc82ac323ae1a978e538cce31256dead42ce87cef0cbcefd09b106e6db7cc400d404468427c11fb15f8f728 SHA512 921255f6ff635f64753ec0d230bcc26f5ee69fe7160528fd077a6b8f4f6237a7e87bbe6a42b0a2463bfdc8fe466499ca15350e388477ebeaded7ab8335305c54
DIST vscodium-1.78.2.23132-arm64.tar.gz 119733620 BLAKE2B 95b6cdfa97a02fa18e5a053b5333bcd347b2f2ed4b4a3630c060606a3a79b44e0e12c90c7d98ca86c207963f8711556f58cbab81ff45fcc6c21c0ed3f3b46824 SHA512 aeaea958574b4ce760e9dffd400c0dd3c52eabc228b55d8e6539d3ca611741e81de8e0c86cbe3d72678c5459f70ebd682a9d69fc5857e3c433366c111094d5d9
+DIST vscodium-1.79.0.23159-amd64.tar.gz 120597824 BLAKE2B 0219ea4bffcbc9353ac002037a820e9fd36d7af525c685ee92db63e9b8d8027712ecd892d1b8d4eeffe3d1782e6c794744c0ef6c576b001c4e798f2c5cd81c45 SHA512 0fbdaf930b6d2c13c87fb39bcfcfd77b086b31e9f11ffe19e223ebc72b9ff26e0563c00d143846bc589160f3839cc1245855b235f6af488fd3de0167a32f1487
+DIST vscodium-1.79.0.23159-arm.tar.gz 109325368 BLAKE2B 0f322ba23926052e873ee58b8a8839ae2a8d5730915cbce20ede7e5e8809a0b0742600be96b1760c82debd1ac3a3663c8437020315efc6b667094d0927bf03ae SHA512 c329e7c323e87537951eed63a72401554f2e241ef15b971f44f8516fa9766a5ed335e074a797ad98548b30102dba827fa649f1479f072b68abb306c626ca16ee
+DIST vscodium-1.79.0.23159-arm64.tar.gz 120850283 BLAKE2B ab8edcf8870fe1584c508a4943a86e5c327d2a309139ac86fed0d9f201c950a47f4966664495e2a8bef6727abd531acde5d78e014fc016da632391c45c25a162 SHA512 a8a7780ca0beb8e6784e3eaeb0a516c8b07f40e9bd1b785259df4ec6c64bf89d2eb6d4d6feaeb1106304ffa002d14c5b238d06d5dbd2455841372db9d0fc6234
diff --git a/app-editors/vscodium/vscodium-1.79.0.23159.ebuild b/app-editors/vscodium/vscodium-1.79.0.23159.ebuild
new file mode 100644
index 000000000000..23943923794c
--- /dev/null
+++ b/app-editors/vscodium/vscodium-1.79.0.23159.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop pax-utils xdg optfeature
+
+DESCRIPTION="A community-driven, freely-licensed binary distribution of Microsoft's VSCode"
+HOMEPAGE="https://vscodium.com/"
+SRC_URI="
+ amd64? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-x64-${PV}.tar.gz -> ${P}-amd64.tar.gz )
+ arm? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-armhf-${PV}.tar.gz -> ${P}-arm.tar.gz )
+ arm64? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-arm64-${PV}.tar.gz -> ${P}-arm64.tar.gz )
+"
+
+RESTRICT="strip bindist"
+
+LICENSE="
+ Apache-2.0
+ BSD
+ BSD-1
+ BSD-2
+ BSD-4
+ CC-BY-4.0
+ ISC
+ LGPL-2.1+
+ MIT
+ MPL-2.0
+ openssl
+ PYTHON
+ TextMate-bundle
+ Unlicense
+ UoI-NCSA
+ W3C
+"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~arm64"
+IUSE=""
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ app-crypt/libsecret[crypt]
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/mesa
+ net-print/cups
+ sys-apps/util-linux
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libxkbfile
+ x11-libs/libXrandr
+ x11-libs/libxshmfence
+ x11-libs/pango
+"
+
+QA_PREBUILT="
+ /opt/vscode/bin/code-tunnel
+ /opt/vscodium/chrome_crashpad_handler
+ /opt/vscodium/chrome-sandbox
+ /opt/vscodium/codium
+ /opt/vscodium/libEGL.so
+ /opt/vscodium/libffmpeg.so
+ /opt/vscodium/libGLESv2.so
+ /opt/vscodium/libvk_swiftshader.so
+ /opt/vscodium/libvulkan.so*
+ /opt/vscodium/resources/app/extensions/*
+ /opt/vscodium/resources/app/node_modules.asar.unpacked/*
+ /opt/vscodium/swiftshader/libEGL.so
+ /opt/vscodium/swiftshader/libGLESv2.so
+"
+
+S="${WORKDIR}"
+
+src_install() {
+ # Cleanup
+ rm "${S}/resources/app/LICENSE.txt" || die
+
+ # Disable update server
+ sed -i "/updateUrl/d" "${S}"/resources/app/product.json || die
+
+ # Install
+ pax-mark m codium
+ mkdir -p "${ED}/opt/${PN}" || die
+ cp -r . "${ED}/opt/${PN}" || die
+ fperms 4711 /opt/${PN}/chrome-sandbox
+
+ dosym -r "/opt/${PN}/bin/codium" "usr/bin/vscodium"
+ dosym -r "/opt/${PN}/bin/codium" "usr/bin/codium"
+ domenu "${FILESDIR}/vscodium.desktop"
+ domenu "${FILESDIR}/vscodium-url-handler.desktop"
+ domenu "${FILESDIR}/vscodium-wayland.desktop"
+ domenu "${FILESDIR}/vscodium-url-handler-wayland.desktop"
+ newicon "resources/app/resources/linux/code.png" "vscodium.png"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ elog "When compared to the regular VSCode, VSCodium has a few quirks"
+ elog "More information at: https://github.com/VSCodium/vscodium/blob/master/DOCS.md"
+ optfeature "keyring support inside vscode" "gnome-base/gnome-keyring"
+}