summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2020-03-12 15:49:24 +0100
committerUlrich Müller <ulm@gentoo.org>2020-03-12 15:52:57 +0100
commitdd491221654b5c19d1e63b3061687671e6451e70 (patch)
tree1afeef3f5da031a5142885dd9ffb4788461f60a1 /app-emacs/bbdb/bbdb-3.2_pre20180106.ebuild
parentapp-emacs/bbdb: Don't install the GNU Info file. (diff)
downloadgentoo-dd491221654b5c19d1e63b3061687671e6451e70.tar.gz
gentoo-dd491221654b5c19d1e63b3061687671e6451e70.tar.bz2
gentoo-dd491221654b5c19d1e63b3061687671e6451e70.zip
app-emacs/bbdb: Version bump to 3.2_pre20180106.
The upstream repo has a v3.2 tag, but there is no release tarball in the download area. The tarball that can be downloaded from cgit is incomplete (e.g., it doesn't contain a configure file). Therefore treat this like a prerelease snapshot and add a _pre suffix. Package-Manager: Portage-2.3.93, Repoman-2.3.20 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/bbdb/bbdb-3.2_pre20180106.ebuild')
-rw-r--r--app-emacs/bbdb/bbdb-3.2_pre20180106.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/app-emacs/bbdb/bbdb-3.2_pre20180106.ebuild b/app-emacs/bbdb/bbdb-3.2_pre20180106.ebuild
new file mode 100644
index 000000000000..8dc25fd9b6bd
--- /dev/null
+++ b/app-emacs/bbdb/bbdb-3.2_pre20180106.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp autotools
+
+MY_P="${P%_pre*}"
+DESCRIPTION="The Insidious Big Brother Database"
+HOMEPAGE="https://savannah.nongnu.org/projects/bbdb/"
+#SRC_URI="https://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz"
+SRC_URI="https://git.savannah.nongnu.org/cgit/bbdb.git/snapshot/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-3+ GPL-1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+IUSE="tex vm"
+RESTRICT="test" #631700
+
+BDEPEND="vm? ( app-emacs/vm )"
+RDEPEND="${BDEPEND}
+ tex? ( virtual/latex-base )"
+
+SITEFILE="50${PN}-gentoo-3.2.el"
+TEXMF="/usr/share/texmf-site"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-lispdir="${EPREFIX}${SITELISP}/${PN}" \
+ "$(use_with vm vm-dir "${EPREFIX}${SITELISP}/vm")"
+}
+
+src_compile() {
+ emake -C lisp
+}
+
+src_install() {
+ emake -C lisp DESTDIR="${D}" install
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ if use tex; then
+ insinto "${TEXMF}"/tex/latex/${PN}
+ doins tex/bbdb.sty
+ fi
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ use tex && texconfig rehash
+}
+
+pkg_postrm() {
+ elisp-site-regen
+ use tex && texconfig rehash
+}