summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-04-10 19:31:28 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-04-10 22:02:01 +0200
commitc9269d95522eedd2c9d8ea7d9fca808c3a4cf0f5 (patch)
tree4eb1873d2a7ca4a5e74f4927dd51b94d839cd02b /app-emacs/counsel/counsel-0.13.4.ebuild
parentapp-emacs/swiper: new package; add version 0.13.4 (diff)
downloadgentoo-c9269d95522eedd2c9d8ea7d9fca808c3a4cf0f5.tar.gz
gentoo-c9269d95522eedd2c9d8ea7d9fca808c3a4cf0f5.tar.bz2
gentoo-c9269d95522eedd2c9d8ea7d9fca808c3a4cf0f5.zip
app-emacs/counsel: new package; add version 0.13.4
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/counsel/counsel-0.13.4.ebuild')
-rw-r--r--app-emacs/counsel/counsel-0.13.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-emacs/counsel/counsel-0.13.4.ebuild b/app-emacs/counsel/counsel-0.13.4.ebuild
new file mode 100644
index 000000000000..fe5b3a0a93e8
--- /dev/null
+++ b/app-emacs/counsel/counsel-0.13.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24.5
+
+inherit elisp
+
+DESCRIPTION="Versions of common Emacs commands customized to make the best use of ivy"
+HOMEPAGE="https://github.com/abo-abo/swiper/"
+SRC_URI="https://github.com/abo-abo/swiper/archive/${PV}.tar.gz
+ -> swiper-${PV}.tar.gz"
+S="${WORKDIR}"/swiper-${PV}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test" # Ivy, Swiper and Counsel tests are performed in app-emacs/ivy
+
+RDEPEND="
+ >=app-emacs/ivy-${PV}
+ >=app-emacs/swiper-${PV}
+"
+BDEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile ${PN}.el
+}
+
+src_install() {
+ elisp-install ${PN} ${PN}.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}