summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-01-08 18:53:45 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-01-08 20:22:41 +0100
commit27457014475a7c65dfec167ef4b1dc4265e865fa (patch)
treec6173ca735e4033a5f1b8cdc82c4c9e148f7920d /app-emacs/fsharp-mode/fsharp-mode-2.0_p20230622.ebuild
parentapp-emacs/fsharp-mode: drop old 1.10_p20211229 (diff)
downloadgentoo-27457014475a7c65dfec167ef4b1dc4265e865fa.tar.gz
gentoo-27457014475a7c65dfec167ef4b1dc4265e865fa.tar.bz2
gentoo-27457014475a7c65dfec167ef4b1dc4265e865fa.zip
app-emacs/fsharp-mode: bump to 2.0_p20230622
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/fsharp-mode/fsharp-mode-2.0_p20230622.ebuild')
-rw-r--r--app-emacs/fsharp-mode/fsharp-mode-2.0_p20230622.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-emacs/fsharp-mode/fsharp-mode-2.0_p20230622.ebuild b/app-emacs/fsharp-mode/fsharp-mode-2.0_p20230622.ebuild
new file mode 100644
index 000000000000..f01f85ed5720
--- /dev/null
+++ b/app-emacs/fsharp-mode/fsharp-mode-2.0_p20230622.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+COMMIT=b4d31c3da018cfbb3d1f9e6fd416d8777f0835bd
+NEED_EMACS=29.1 # To compile full suite including Eglot, introduced in 29.1.
+
+inherit elisp
+
+DESCRIPTION="Support for the F# programming language"
+HOMEPAGE="https://github.com/fsharp/emacs-fsharp-mode/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fsharp/emacs-${PN}.git"
+else
+ SRC_URI="https://github.com/fsharp/emacs-${PN}/archive/${COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/emacs-${PN}-${COMMIT}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+DOCS=( CHANGELOG.md README.org )
+ELISP_REMOVE="test/fsi-tests.el test/integration-tests.el"
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests buttercup test