summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2019-05-04 14:51:59 +0200
committerUlrich Müller <ulm@gentoo.org>2019-05-04 15:33:39 +0200
commit2b454725d9d5795f06be5713428ee70516475d2d (patch)
treefba4608b73363c63a7bd684f7fa413a20c0de8b9 /app-emacs/helm/helm-3.2.ebuild
parentapp-emacs/async: Initial import. (diff)
downloadgentoo-2b454725d9d5795f06be5713428ee70516475d2d.tar.gz
gentoo-2b454725d9d5795f06be5713428ee70516475d2d.tar.bz2
gentoo-2b454725d9d5795f06be5713428ee70516475d2d.zip
app-emacs/helm: Initial import.
This is the successor to app-emacs/anything, according to https://www.emacswiki.org/emacs/Anything. Ebuild contributed by me. Package-Manager: Portage-2.3.65, Repoman-2.3.12 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/helm/helm-3.2.ebuild')
-rw-r--r--app-emacs/helm/helm-3.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-emacs/helm/helm-3.2.ebuild b/app-emacs/helm/helm-3.2.ebuild
new file mode 100644
index 000000000000..f852381e5353
--- /dev/null
+++ b/app-emacs/helm/helm-3.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp
+
+DESCRIPTION="Emacs incremental completion and selection narrowing framework"
+HOMEPAGE="https://emacs-helm.github.io/helm/"
+SRC_URI="https://github.com/emacs-helm/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="app-emacs/async
+ app-emacs/popup"
+BDEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}
+
+src_install() {
+ elisp_src_install
+ exeinto "${SITEETC}/${PN}"
+ doexe emacs-helm.sh
+}