summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-12-15 23:33:32 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-12-16 00:32:11 +0100
commite7ae6ad5f749203c854a664fb100e521e739d6a1 (patch)
tree86fc4ac68e569eeb8631ae256b15121004be1fac /app-emacs/racket-mode/racket-mode-1_p20230506.ebuild
parentdev-libs/ppl: use $P in SRC_URI to fix a pkgcheck warning (diff)
downloadgentoo-e7ae6ad5f749203c854a664fb100e521e739d6a1.tar.gz
gentoo-e7ae6ad5f749203c854a664fb100e521e739d6a1.tar.bz2
gentoo-e7ae6ad5f749203c854a664fb100e521e739d6a1.zip
app-emacs/racket-mode: drop old 1_p20230506
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/racket-mode/racket-mode-1_p20230506.ebuild')
-rw-r--r--app-emacs/racket-mode/racket-mode-1_p20230506.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/app-emacs/racket-mode/racket-mode-1_p20230506.ebuild b/app-emacs/racket-mode/racket-mode-1_p20230506.ebuild
deleted file mode 100644
index 7690b9a62668..000000000000
--- a/app-emacs/racket-mode/racket-mode-1_p20230506.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-[[ ${PV} == *_p20230506 ]] && COMMIT=c2fe266c18bb6e55a13c7ba795b0a5f7372b6c13
-
-inherit elisp
-
-DESCRIPTION="Emacs modes for Racket: edit, REPL, check-syntax, debug, profile, and more"
-HOMEPAGE="https://www.racket-mode.com/
- https://github.com/greghendershott/racket-mode/"
-SRC_URI="https://github.com/greghendershott/${PN}/archive/${COMMIT}.tar.gz
- -> ${P}.tar.gz"
-S="${WORKDIR}"/${PN}-${COMMIT}
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-
-RDEPEND="dev-scheme/racket:=[-minimal]"
-BDEPEND="${RDEPEND}"
-
-PATCHES=( "${FILESDIR}"/${PN}-rkt-source-dir.patch )
-
-DOCS=( CONTRIBUTING.org README.org THANKS.org )
-ELISP_TEXINFO="doc/racket-mode.texi"
-SITEFILE="50${PN}-gentoo.el"
-
-src_prepare() {
- elisp_src_prepare
-
- sed "s|@SITEETC@|${SITEETC}/${PN}|" -i "${S}"/racket-util.el || die
-}
-
-src_compile() {
- elisp_src_compile
-
- # Equivalent to compiling from Emacs with "racket-mode-start-faster",
- # because this is installed globally we have to compile it now.
- ebegin "Compiling Racket source files"
- find "${S}"/racket -type f -name "*.rkt" -exec raco make -v {} +
- eend $? "failed to compile Racket source files" || die
-}
-
-src_test() {
- # Set "PLTUSERHOME" to a safe temp directory to prevent writing to ~.
- PLTUSERHOME="${T}"/racket-mode/test-racket emake test-racket
-}
-
-src_install() {
- elisp_src_install
-
- # Install Racket files to "${SITEETC}".
- insinto "${SITEETC}/${PN}"
- doins -r racket
-}