summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2018-06-02 21:53:30 +0200
committerUlrich Müller <ulm@gentoo.org>2018-06-02 22:02:40 +0200
commit56671a0fe3a07439c1b7690a5e6f4b8ab78bffdc (patch)
tree3d8daffee59105b3f1960a4098c4adb39d823119 /app-emacs/yasnippet/yasnippet-0.13.0.ebuild
parentapp-emacs/yasnippet: Remove old. (diff)
downloadgentoo-56671a0fe3a07439c1b7690a5e6f4b8ab78bffdc.tar.gz
gentoo-56671a0fe3a07439c1b7690a5e6f4b8ab78bffdc.tar.bz2
gentoo-56671a0fe3a07439c1b7690a5e6f4b8ab78bffdc.zip
app-emacs/yasnippet: Version bump.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-emacs/yasnippet/yasnippet-0.13.0.ebuild')
-rw-r--r--app-emacs/yasnippet/yasnippet-0.13.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-emacs/yasnippet/yasnippet-0.13.0.ebuild b/app-emacs/yasnippet/yasnippet-0.13.0.ebuild
new file mode 100644
index 000000000000..e6ba47b23dc4
--- /dev/null
+++ b/app-emacs/yasnippet/yasnippet-0.13.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit elisp readme.gentoo-r1
+
+DESCRIPTION="Yet another snippet extension for Emacs"
+HOMEPAGE="http://joaotavora.github.com/yasnippet/"
+SRC_URI="https://github.com/joaotavora/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+SITEFILE="50${PN}-gentoo-${PV}.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . -l yasnippet-tests \
+ -f ert-run-tests-batch-and-exit
+}
+
+src_install() {
+ elisp-install ${PN} yasnippet.el{,c} yasnippet-debug.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc CONTRIBUTING.md NEWS README.mdown
+ use doc && dodoc -r doc/*
+
+ DOC_CONTENTS="Add the following to your ~/.emacs to use YASnippet:
+ \n\t(require 'yasnippet)
+ \n\t(yas-global-mode 1)
+ \n\nYASnippet no longer bundles snippets directly. Install the package
+ app-emacs/yasnippet-snippets for a collection of snippets."
+ readme.gentoo_create_doc
+}