summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Turner <jturner.usa+gentoo@gmail.com>2021-09-17 00:30:40 -0400
committerSam James <sam@gentoo.org>2021-09-18 03:53:19 +0100
commit0cd8b1169e2076787b5582e33fa2af423f1a7715 (patch)
tree6b036ff7fa20e6eeebd1b36443a89ef8f0e1bb34 /app-emacs
parentapp-emacs/epl: created ebuild (diff)
downloadgentoo-0cd8b1169e2076787b5582e33fa2af423f1a7715.tar.gz
gentoo-0cd8b1169e2076787b5582e33fa2af423f1a7715.tar.bz2
gentoo-0cd8b1169e2076787b5582e33fa2af423f1a7715.zip
app-emacs/pkg-info: created ebuild
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: John Turner <jturner.usa+gentoo@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/pkg-info/Manifest1
-rw-r--r--app-emacs/pkg-info/files/50pkg-info-gentoo.el8
-rw-r--r--app-emacs/pkg-info/metadata.xml16
-rw-r--r--app-emacs/pkg-info/pkg-info-0.6.ebuild22
4 files changed, 47 insertions, 0 deletions
diff --git a/app-emacs/pkg-info/Manifest b/app-emacs/pkg-info/Manifest
new file mode 100644
index 000000000000..fb2e34aa09fd
--- /dev/null
+++ b/app-emacs/pkg-info/Manifest
@@ -0,0 +1 @@
+DIST pkg-info-0.6.tar.gz 18896 BLAKE2B 464f172ef9e0e6e89f472032b1be0506c49a51fc8e2120ac561be23187fbd0ca64abf021e2ef717267623efe8ff0a49c14ad1af098f9ff20e167b334c49081d2 SHA512 73531a0a7ab54cf3e365a627d2905cc820f1328ad8ca8f985d1954c877f4a1ad7dc5129f52c4e2accd305661a9b952da9adf0a802c8ab6f35e1c16b55966ef54
diff --git a/app-emacs/pkg-info/files/50pkg-info-gentoo.el b/app-emacs/pkg-info/files/50pkg-info-gentoo.el
new file mode 100644
index 000000000000..352457a2380c
--- /dev/null
+++ b/app-emacs/pkg-info/files/50pkg-info-gentoo.el
@@ -0,0 +1,8 @@
+;;; pkg-info site-lisp configuration
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'pkg-info-library-original-version "pkg-info" nil t)
+(autoload 'pkg-info-library-version "pkg-info" nil t)
+(autoload 'pkg-info-defining-library-original-version "pkg-info" nil t)
+(autoload 'pkg-info-defining-library-version "pkg-info" nil t)
+(autoload 'pkg-info-package-version "pkg-info" nil t)
+(autoload 'pkg-info-version-info "pkg-info" nil t)
diff --git a/app-emacs/pkg-info/metadata.xml b/app-emacs/pkg-info/metadata.xml
new file mode 100644
index 000000000000..8ff3d9d5f463
--- /dev/null
+++ b/app-emacs/pkg-info/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>jturner.usa+gentoo@gmail.com</email>
+ <name>John Turner</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">emacsorphanage/pkg-info</remote-id>
+ <doc>https://github.com/emacsorphanage/pkg-info/blob/master/README.md</doc>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/pkg-info/pkg-info-0.6.ebuild b/app-emacs/pkg-info/pkg-info-0.6.ebuild
new file mode 100644
index 000000000000..a9a870f2370a
--- /dev/null
+++ b/app-emacs/pkg-info/pkg-info-0.6.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+NEED_EMACS="24.1"
+
+inherit elisp
+
+DESCRIPTION="Provide information about Emacs packages"
+HOMEPAGE="https://github.com/emacsorphanage/pkg-info"
+SRC_URI="https://github.com/emacsorphanage/pkg-info/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test" # test requires cask and ert-runner which are not packaged
+
+RDEPEND=">=app-emacs/epl-0.8"
+
+SITEFILE="50${PN}-gentoo.el"
+DOCS=( README.md CHANGES.md )