summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-04-08 22:56:20 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-04-09 00:00:10 +0200
commita8bdbbb222c43d63dbc7fbf06acdb926f7d94d5a (patch)
tree3b0f8c856b21f97d7485f83930978f81bc196845 /app-emacs
parentapp-emacs/treemacs: bump to 3.1_p20240229 (diff)
downloadgentoo-a8bdbbb222c43d63dbc7fbf06acdb926f7d94d5a.tar.gz
gentoo-a8bdbbb222c43d63dbc7fbf06acdb926f7d94d5a.tar.bz2
gentoo-a8bdbbb222c43d63dbc7fbf06acdb926f7d94d5a.zip
app-emacs/lsp-treemacs: bump to 0.5
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/lsp-treemacs/Manifest1
-rw-r--r--app-emacs/lsp-treemacs/lsp-treemacs-0.5.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/app-emacs/lsp-treemacs/Manifest b/app-emacs/lsp-treemacs/Manifest
index 0da450066a20..82f006af6aee 100644
--- a/app-emacs/lsp-treemacs/Manifest
+++ b/app-emacs/lsp-treemacs/Manifest
@@ -1 +1,2 @@
DIST lsp-treemacs-0.4.tar.gz 1414056 BLAKE2B 508032a0514cb32e6f05974966dcc035d35f4780ef936f730901c3b5c9d5ab3f632ae22faf0a37fb81cf0e3388e53453c28e304f48ee5a8e090c9b771db47caf SHA512 e9e7ae5459c924d201fd164eaf245fd872187388bf9ead39e51962ad867919a7511f23543da01c17cad08f3fc0fe7b7607d6a2a5bc4d04dd392c6e6c5f3374d3
+DIST lsp-treemacs-0.5.tar.gz 1412531 BLAKE2B 68c4513cc72d87548b86de5ec346f583f09f97d440dcab94f220deb8b3657e9c002641b482e9f7243ff2a608120201d90408540ba8ecd1a0849fd19b7cf43b69 SHA512 37c33ac7fbf76383b801f7194c0aebb8f119a1c47ae88932201d8ce6a33720c19d1f48d2975d34c07fc4d35c2a2e8c50b1cdfb55a7d9f4bd9967228a86f342df
diff --git a/app-emacs/lsp-treemacs/lsp-treemacs-0.5.ebuild b/app-emacs/lsp-treemacs/lsp-treemacs-0.5.ebuild
new file mode 100644
index 000000000000..cbac4912883c
--- /dev/null
+++ b/app-emacs/lsp-treemacs/lsp-treemacs-0.5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Integration between lsp-mode and treemacs"
+HOMEPAGE="https://github.com/emacs-lsp/lsp-treemacs/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/emacs-lsp/${PN}"
+else
+ SRC_URI="https://github.com/emacs-lsp/${PN}/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ app-emacs/dash
+ app-emacs/f
+ app-emacs/ht
+ app-emacs/lsp-mode
+ app-emacs/treemacs
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-themes-icon-directory.patch"
+)
+
+DOCS=( README.org screenshots )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ elisp_src_prepare
+
+ sed -e "s|@SITEETC@|${SITEETC}/${PN}|" -i "${PN}-themes.el" || die
+}
+
+src_install() {
+ elisp_src_install
+
+ insinto "${SITEETC}/${PN}"
+ doins -r icons
+}