summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Sarnie <sarnex@gentoo.org>2021-11-22 21:43:46 -0500
committerNick Sarnie <sarnex@gentoo.org>2021-11-22 21:51:02 -0500
commitdf7521d25d089e75e0fbaaccf2dc2cbb33143cae (patch)
tree067b80bc9cacb15008795d880b95576bd3192035 /app-emulation/wine-mono/wine-mono-7.0.0.ebuild
parentsci-mathematics/nauty: new upstream version 2.7.3. (diff)
downloadgentoo-df7521d25d089e75e0fbaaccf2dc2cbb33143cae.tar.gz
gentoo-df7521d25d089e75e0fbaaccf2dc2cbb33143cae.tar.bz2
gentoo-df7521d25d089e75e0fbaaccf2dc2cbb33143cae.zip
app-emulation/wine-mono: Sync with ::wine
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
Diffstat (limited to 'app-emulation/wine-mono/wine-mono-7.0.0.ebuild')
-rw-r--r--app-emulation/wine-mono/wine-mono-7.0.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-emulation/wine-mono/wine-mono-7.0.0.ebuild b/app-emulation/wine-mono/wine-mono-7.0.0.ebuild
new file mode 100644
index 000000000000..b396802d99cc
--- /dev/null
+++ b/app-emulation/wine-mono/wine-mono-7.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Wine Mono is a replacement for the .NET runtime and class libraries in Wine"
+HOMEPAGE="https://www.winehq.org/"
+SRC_URI="
+ !shared? ( https://dl.winehq.org/wine/${PN}/${PV}/${P}-x86.msi )
+ shared? ( https://dl.winehq.org/wine/${PN}/${PV}/${P}-x86.tar.xz )
+"
+
+LICENSE="BSD-2 GPL-2 LGPL-2.1 MIT MPL-1.1"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+shared"
+
+DEPEND="!!app-emulation/wine:0"
+
+S="${WORKDIR}"
+
+src_install() {
+ insinto /usr/share/wine/mono
+ if use shared; then
+ doins -r "${P}"
+ else
+ doins "${DISTDIR}/${P}-x86.msi"
+ fi
+}