summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2021-12-01 20:00:05 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-12-01 20:02:18 +0200
commitf3a7e2703c8116c47712b99453c1fe973cea5b3b (patch)
treeb352c15c0bddb9813ac5f5df9cb6d5772b68a32a /app-emulation
parentapp-emulation/crun: add 1.3 (diff)
downloadgentoo-f3a7e2703c8116c47712b99453c1fe973cea5b3b.tar.gz
gentoo-f3a7e2703c8116c47712b99453c1fe973cea5b3b.tar.bz2
gentoo-f3a7e2703c8116c47712b99453c1fe973cea5b3b.zip
app-emulation/crun: disable py3.7, add missing BDEPEND
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/crun/crun-1.3.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/app-emulation/crun/crun-1.3.ebuild b/app-emulation/crun/crun-1.3.ebuild
index 29ed772f9849..6461366af873 100644
--- a/app-emulation/crun/crun-1.3.ebuild
+++ b/app-emulation/crun/crun-1.3.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{7..10} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit autotools python-any-r1
@@ -25,7 +25,10 @@ DEPEND="
systemd? ( sys-apps/systemd:= )
"
RDEPEND="${DEPEND}"
-BDEPEND="${PYTHON_DEPS}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+"
# the crun test suite is comprehensive to the extent that tests will fail
# within a sandbox environment, due to the nature of the privileges