summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2020-05-27 21:42:43 +0900
committerAkinori Hattori <hattya@gentoo.org>2020-05-27 21:42:43 +0900
commit09ec0b7f53c00b7a400d0ca58c87ac3234c04d58 (patch)
tree2b901818e6b854c7503425ae225aef32ce311183 /app-i18n/ibus-typing-booster/ibus-typing-booster-2.9.0.ebuild
parentmedia-libs/compface: fix configure (diff)
downloadgentoo-09ec0b7f53c00b7a400d0ca58c87ac3234c04d58.tar.gz
gentoo-09ec0b7f53c00b7a400d0ca58c87ac3234c04d58.tar.bz2
gentoo-09ec0b7f53c00b7a400d0ca58c87ac3234c04d58.zip
app-i18n/ibus-typing-booster: new upstream release
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n/ibus-typing-booster/ibus-typing-booster-2.9.0.ebuild')
-rw-r--r--app-i18n/ibus-typing-booster/ibus-typing-booster-2.9.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.9.0.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.9.0.ebuild
new file mode 100644
index 000000000000..ed1abe745449
--- /dev/null
+++ b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.9.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Completion input method for IBus"
+HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
+SRC_URI="https://github.com/mike-fabian/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/m17n-lib
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_MULTI_USEDEP}]
+ dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyenchant[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyxdg[${PYTHON_MULTI_USEDEP}]
+ ')"
+RDEPEND="${DEPEND}
+ >=dev-db/m17n-db-1.7"
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}