summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2019-12-14 10:55:56 +0100
committerUlrich Müller <ulm@gentoo.org>2019-12-14 10:57:15 +0100
commit47d0d73ec00762f6585526dc3c5c9c129a3a07a6 (patch)
tree06ac5c0f02f7ab287a77120472d7160e50f41fd7 /app-i18n
parentapp-i18n/man-pages-de: Fix file collision with sys-process/procps. (diff)
downloadgentoo-47d0d73ec00762f6585526dc3c5c9c129a3a07a6.tar.gz
gentoo-47d0d73ec00762f6585526dc3c5c9c129a3a07a6.tar.bz2
gentoo-47d0d73ec00762f6585526dc3c5c9c129a3a07a6.zip
app-i18n/man-pages-pl: Fix file collision with sys-process/procps.
Bug: https://bugs.gentoo.org/702276 Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/man-pages-pl/man-pages-pl-0.7-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-i18n/man-pages-pl/man-pages-pl-0.7-r1.ebuild b/app-i18n/man-pages-pl/man-pages-pl-0.7-r1.ebuild
new file mode 100644
index 000000000000..ef7e788c0ad6
--- /dev/null
+++ b/app-i18n/man-pages-pl/man-pages-pl-0.7-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PKG=manpages-pl-${PV}
+
+DESCRIPTION="A collection of Polish translations of Linux manual pages"
+HOMEPAGE="https://sourceforge.net/projects/manpages-pl/"
+SRC_URI="mirror://sourceforge/manpages-pl/${MY_PKG}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+
+DOCS=( AUTHORS README )
+
+S="${WORKDIR}/${MY_PKG}"
+
+src_prepare() {
+ default
+
+ #mans provided by other packages
+ rm generated/man1/{free,groups,uptime}.1 \
+ po/man1/{free,groups,uptime}.1.po \
+ || die "Failed to clean up duplicates from build directory!"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" COMPRESSOR=:
+}