summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2017-10-19 22:52:30 +0200
committerMike Gilbert <floppym@gentoo.org>2017-10-23 13:24:42 -0400
commita83f2edc68355376106c96a88e604d417a2c6393 (patch)
tree7ea3d488dd06454bd671fdabe78d62bbb16174c6 /app-i18n
parentapp-i18n/fcitx-rime: Version bump (0.3.2). (diff)
downloadgentoo-a83f2edc68355376106c96a88e604d417a2c6393.tar.gz
gentoo-a83f2edc68355376106c96a88e604d417a2c6393.tar.bz2
gentoo-a83f2edc68355376106c96a88e604d417a2c6393.zip
app-i18n/fcitx-rime: Add live ebuild.
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/fcitx-rime/fcitx-rime-4.9999.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-i18n/fcitx-rime/fcitx-rime-4.9999.ebuild b/app-i18n/fcitx-rime/fcitx-rime-4.9999.ebuild
new file mode 100644
index 000000000000..35443f12a6e1
--- /dev/null
+++ b/app-i18n/fcitx-rime/fcitx-rime-4.9999.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils gnome2-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fcitx/fcitx-rime"
+fi
+
+DESCRIPTION="Chinese RIME input method for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx-rime"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.9:4
+ >=app-i18n/librime-1.0.0:=
+ app-i18n/rime-data
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=()
+
+src_configure() {
+ local mycmakeargs=(
+ -DRIME_DATA_DIR="${EPREFIX}/usr/share/rime-data"
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}