summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorfulgurance <zohran.londais@gmail.com>2019-05-03 17:10:59 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-08-20 15:41:31 +0300
commit1f3c291a1d794868c714acf741974563d9ff8791 (patch)
treecdd6a59397ae9c8f5187b404c72b88f2f4e95814 /app-laptop
parentdev-dotnet/libgdiplus: bump version to 6.0.2 (diff)
downloadgentoo-1f3c291a1d794868c714acf741974563d9ff8791.tar.gz
gentoo-1f3c291a1d794868c714acf741974563d9ff8791.tar.bz2
gentoo-1f3c291a1d794868c714acf741974563d9ff8791.zip
app-laptop/msi-keyboard: New package
Control backlight of MSI laptop keyboards Package-Manager: Portage 2.3.72, Repoman 2.3.17 Signed-off-by: Zohran Londais <zohran.londais@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/11884 Closes: https://github.com/gentoo/gentoo/pull/10476 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/msi-keyboard/Manifest1
-rw-r--r--app-laptop/msi-keyboard/files/msi-keyboard-1.0-makefile.patch20
-rw-r--r--app-laptop/msi-keyboard/metadata.xml11
-rw-r--r--app-laptop/msi-keyboard/msi-keyboard-1.0.ebuild26
4 files changed, 58 insertions, 0 deletions
diff --git a/app-laptop/msi-keyboard/Manifest b/app-laptop/msi-keyboard/Manifest
new file mode 100644
index 000000000000..8931d70a6960
--- /dev/null
+++ b/app-laptop/msi-keyboard/Manifest
@@ -0,0 +1 @@
+DIST msi-keyboard-1.0.tar.gz 15182 BLAKE2B 4c084e1522da926e541b18d0e59044aeb83873516b3ec5b5bd980883b923acee21842c3612910d84008f66556b6c9e2f9d0c7e588f6aecf242a0e54d72e9c3a3 SHA512 542f74b8eb77db4ef0b26fc5c671bc7446d37b88e13855927d5cdd68c688f933e46b5a377d0f5ec496c1e35694789ae82694d31fc70f04d5059fe60f2ea9d24a
diff --git a/app-laptop/msi-keyboard/files/msi-keyboard-1.0-makefile.patch b/app-laptop/msi-keyboard/files/msi-keyboard-1.0-makefile.patch
new file mode 100644
index 000000000000..08cdaa79e235
--- /dev/null
+++ b/app-laptop/msi-keyboard/files/msi-keyboard-1.0-makefile.patch
@@ -0,0 +1,20 @@
+--- a/Makefile 2019-08-19 22:40:43.258528097 +0200
++++ b/Makefile 2019-08-19 23:00:30.786462412 +0200
+@@ -1,6 +1,4 @@
+ CC=g++
+-CFLAGS=-c -Wall
+-LDFLAGS=-lhidapi-libusb
+ SOURCES=main.cpp Keyboard.cpp Color.cpp
+ OBJECTS=$(SOURCES:.cpp=.o)
+ EXECUTABLE=msi-keyboard
+@@ -11,8 +9,7 @@
+ rm $(OBJECTS) $(EXECUTABLE)
+
+ $(EXECUTABLE): $(OBJECTS)
+- $(CC) $(LDFLAGS) $(OBJECTS) -o $@
++ $(CC) $(CFLAGS) -lhidapi-libusb $(LDFLAGS) $(OBJECTS) -o $@
+
+ .cpp.o:
+- $(CC) $(CFLAGS) $< -o $@
+-
++ $(CC) $(CFLAGS) -c $< -o $@
diff --git a/app-laptop/msi-keyboard/metadata.xml b/app-laptop/msi-keyboard/metadata.xml
new file mode 100644
index 000000000000..5c41b33f0a4b
--- /dev/null
+++ b/app-laptop/msi-keyboard/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zohran.londais@gmail.com</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-laptop/msi-keyboard/msi-keyboard-1.0.ebuild b/app-laptop/msi-keyboard/msi-keyboard-1.0.ebuild
new file mode 100644
index 000000000000..7e074cc86a8a
--- /dev/null
+++ b/app-laptop/msi-keyboard/msi-keyboard-1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit udev
+
+DESCRIPTION="Control backlight of MSI laptop keyboards"
+HOMEPAGE="https://github.com/makkarpov/msi-keyboard"
+SRC_URI="https://github.com/makkarpov/msi-keyboard/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-libs/hidapi"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-makefile.patch
+)
+
+src_install() {
+ udev_dorules 99-msi-keyboard.rules
+ udev_reload
+ dobin msi-keyboard
+}