summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-laptop/msi-keyboard/msi-keyboard-1.0.ebuild')
-rw-r--r--app-laptop/msi-keyboard/msi-keyboard-1.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-laptop/msi-keyboard/msi-keyboard-1.0.ebuild b/app-laptop/msi-keyboard/msi-keyboard-1.0.ebuild
new file mode 100644
index 000000000000..7e074cc86a8a
--- /dev/null
+++ b/app-laptop/msi-keyboard/msi-keyboard-1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit udev
+
+DESCRIPTION="Control backlight of MSI laptop keyboards"
+HOMEPAGE="https://github.com/makkarpov/msi-keyboard"
+SRC_URI="https://github.com/makkarpov/msi-keyboard/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-libs/hidapi"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-makefile.patch
+)
+
+src_install() {
+ udev_dorules 99-msi-keyboard.rules
+ udev_reload
+ dobin msi-keyboard
+}