summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-09-07 02:45:48 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-09-07 02:46:42 +0200
commitba9f44cddffb2ae8c4a5f759817499a511449966 (patch)
tree32196cb3532e69e815bc0fda7e52b38a0271387d /app-metrics
parentapp-metrics/collectd: bump to v5.12.0 (diff)
downloadgentoo-ba9f44cddffb2ae8c4a5f759817499a511449966.tar.gz
gentoo-ba9f44cddffb2ae8c4a5f759817499a511449966.tar.bz2
gentoo-ba9f44cddffb2ae8c4a5f759817499a511449966.zip
app-metrics/collectd: add gpu_nvidia plugin
Closes: https://bugs.gentoo.org/740106 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'app-metrics')
-rw-r--r--app-metrics/collectd/collectd-5.12.0.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/app-metrics/collectd/collectd-5.12.0.ebuild b/app-metrics/collectd/collectd-5.12.0.ebuild
index e3d3fc157a4f..b4afd4d953e8 100644
--- a/app-metrics/collectd/collectd-5.12.0.ebuild
+++ b/app-metrics/collectd/collectd-5.12.0.ebuild
@@ -52,8 +52,8 @@ COLLECTD_TESTED_PLUGINS="aggregation amqp apache apcups ascent battery bind
buddyinfo capabilities ceph cgroups check_uptime chrony connectivity
conntrack contextswitch cpu cpufreq cpusleep csv curl curl_json
curl_xml dbi df disk dns drbd email entropy ethstat exec fhcount
- filecount fscache gmond gps hddtemp hugepages interface ipc ipmi
- iptables ipvs irq java lua load logfile logparser log_logstash
+ filecount fscache gmond gps gpu_nvidia hddtemp hugepages interface ipc
+ ipmi iptables ipvs irq java lua load logfile logparser log_logstash
madwifi match_empty_counter match_hashed match_regex match_timediff
match_value mbmon mcelog md memcachec memcached memory modbus mqtt
multimeter mysql netlink network network nfs nginx notify_desktop
@@ -101,6 +101,7 @@ COMMON_DEPEND="
collectd_plugins_dns? ( net-libs/libpcap )
collectd_plugins_gmond? ( sys-cluster/ganglia )
collectd_plugins_gps? ( sci-geosciences/gpsd:= )
+ collectd_plugins_gpu_nvidia? ( dev-util/nvidia-cuda-toolkit )
collectd_plugins_ipmi? ( >=sys-libs/openipmi-2.0.16-r1 )
collectd_plugins_iptables? ( >=net-firewall/iptables-1.4.13:0= )
collectd_plugins_log_logstash? ( dev-libs/yajl:= )
@@ -413,6 +414,12 @@ src_configure() {
use collectd_plugins_smart || myconf+=" --with-libatasmart=no"
use collectd_plugins_gps || myconf+=" --with-libgps=no"
+ if use collectd_plugins_gpu_nvidia; then
+ myconf+=" --with-cuda=${EPREFIX}/opt/cuda"
+ else
+ myconf+=" --with-cuda=no"
+ fi
+
if use perl; then
myconf+=" --with-perl-bindings=INSTALLDIRS=vendor"
else