summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Winston <amynka@gentoo.org>2016-11-06 21:45:29 +0100
committerAmy Winston <amynka@gentoo.org>2016-11-06 21:45:29 +0100
commiteee8ee8453c9cbdbffa5e6c7ef0a5a4bcfcc18e4 (patch)
tree698647c4bd4ff423f0c179df541cc7942fe00c7d /app-misc/khal/khal-0.8.3.ebuild
parentsys-kernel/genkernel-next: version bump to 65 (diff)
downloadgentoo-eee8ee8453c9cbdbffa5e6c7ef0a5a4bcfcc18e4.tar.gz
gentoo-eee8ee8453c9cbdbffa5e6c7ef0a5a4bcfcc18e4.tar.bz2
gentoo-eee8ee8453c9cbdbffa5e6c7ef0a5a4bcfcc18e4.zip
app-misc/khal: version bump 0.8.3 bug #592372
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-misc/khal/khal-0.8.3.ebuild')
-rw-r--r--app-misc/khal/khal-0.8.3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-misc/khal/khal-0.8.3.ebuild b/app-misc/khal/khal-0.8.3.ebuild
new file mode 100644
index 000000000000..9bda34779305
--- /dev/null
+++ b/app-misc/khal/khal-0.8.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+PYTHON_COMPAT=( python3_{3,4} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="A CalDAV based calendar"
+HOMEPAGE="http://lostpackets.de/khal/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="zsh-completion"
+
+RDEPEND=">=dev-python/click-3.2[${PYTHON_USEDEP}]
+ dev-python/icalendar[${PYTHON_USEDEP}]
+ dev-python/urwid[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/vdirsyncer[${PYTHON_USEDEP}]
+ dev-python/pkginfo[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ >=dev-python/tzlocal-1.0[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ zsh-completion? ( app-shells/zsh )"
+
+DEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+DOCS=( AUTHORS.txt CHANGELOG.rst CONTRIBUTING.txt README.rst khal.conf.sample )
+
+src_install() {
+ distutils-r1_src_install
+ if use zsh-completion; then
+ insinto /usr/share/zsh/site-functions
+ doins misc/__khal
+ fi
+}