summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-09-02 21:20:50 -0400
committerCraig Andrews <candrews@gentoo.org>2019-09-02 21:28:05 -0400
commit161620f5881bb0cc64d133ea4752ad3884346558 (patch)
treeba1581fcd00c16619966130a14af9a361cd1fe9e /app-misc/neofetch/neofetch-6.1.0.ebuild
parentmedia-plugins/kodi-inputstream-adaptive: Drop dependency on dev-libs/libplatform (diff)
downloadgentoo-161620f5881bb0cc64d133ea4752ad3884346558.tar.gz
gentoo-161620f5881bb0cc64d133ea4752ad3884346558.tar.bz2
gentoo-161620f5881bb0cc64d133ea4752ad3884346558.zip
app-misc/neofetch: 6.1.0 version bump
Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'app-misc/neofetch/neofetch-6.1.0.ebuild')
-rw-r--r--app-misc/neofetch/neofetch-6.1.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-misc/neofetch/neofetch-6.1.0.ebuild b/app-misc/neofetch/neofetch-6.1.0.ebuild
new file mode 100644
index 000000000000..45192c9d63c8
--- /dev/null
+++ b/app-misc/neofetch/neofetch-6.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="https://github.com/dylanaraps/${PN}/archive/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~mips ~x86 ~amd64-fbsd"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/dylanaraps/neofetch.git"
+fi
+
+DESCRIPTION="Simple information system script"
+HOMEPAGE="https://github.com/dylanaraps/neofetch"
+LICENSE="MIT-with-advertising"
+SLOT="0"
+IUSE="X"
+
+RDEPEND="sys-apps/pciutils
+ X? (
+ media-gfx/imagemagick
+ media-libs/imlib2
+ www-client/w3m[imlib]
+ x11-apps/xprop
+ x11-apps/xrandr
+ x11-apps/xwininfo
+ )"