summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/neofetch/neofetch-6.1.0.ebuild')
-rw-r--r--app-misc/neofetch/neofetch-6.1.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-misc/neofetch/neofetch-6.1.0.ebuild b/app-misc/neofetch/neofetch-6.1.0.ebuild
new file mode 100644
index 000000000000..45192c9d63c8
--- /dev/null
+++ b/app-misc/neofetch/neofetch-6.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="https://github.com/dylanaraps/${PN}/archive/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~mips ~x86 ~amd64-fbsd"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/dylanaraps/neofetch.git"
+fi
+
+DESCRIPTION="Simple information system script"
+HOMEPAGE="https://github.com/dylanaraps/neofetch"
+LICENSE="MIT-with-advertising"
+SLOT="0"
+IUSE="X"
+
+RDEPEND="sys-apps/pciutils
+ X? (
+ media-gfx/imagemagick
+ media-libs/imlib2
+ www-client/w3m[imlib]
+ x11-apps/xprop
+ x11-apps/xrandr
+ x11-apps/xwininfo
+ )"