summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-07-10 23:58:39 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-07-10 23:59:01 +0200
commit347fa83be09a9a202d7e16e94bca54264b78cc6b (patch)
treeaeea0ba3bdaff6d5c5e46216d54e0348ee3b9776 /app-misc/ondir/ondir-0.2.4.ebuild
parentdev-python/pytz: use HTTPs (diff)
downloadgentoo-347fa83be09a9a202d7e16e94bca54264b78cc6b.tar.gz
gentoo-347fa83be09a9a202d7e16e94bca54264b78cc6b.tar.bz2
gentoo-347fa83be09a9a202d7e16e94bca54264b78cc6b.zip
app-misc/ondir: version bump.
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'app-misc/ondir/ondir-0.2.4.ebuild')
-rw-r--r--app-misc/ondir/ondir-0.2.4.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-misc/ondir/ondir-0.2.4.ebuild b/app-misc/ondir/ondir-0.2.4.ebuild
new file mode 100644
index 000000000000..2f51ec18dee6
--- /dev/null
+++ b/app-misc/ondir/ondir-0.2.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Automatically execute scripts as you traverse directories"
+HOMEPAGE="http://swapoff.org/OnDir"
+SRC_URI="http://swapoff.org/files/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+DEPEND="sys-apps/sed"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog INSTALL scripts.tcsh scripts.sh )
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s:\(/man/.*$\):/share\1:g" \
+ -e "s:-g:${CFLAGS}:" Makefile || die "sed Makefile failed"
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ PREFIX="${EPREFIX}/usr" \
+ CONF="${EPREFIX}/etc/ondirrc" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ default
+ emake \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}/usr" \
+ CONF="${EPREFIX}/etc/ondirrc" \
+ install
+ newdoc ondirrc.eg ondirrc.example
+}