summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-03 01:18:22 +0000
committerSam James <sam@gentoo.org>2022-01-03 01:19:14 +0000
commite1f7fc1b141be3d636b4c7d3fef203cc0bc96dea (patch)
tree3856d3a5498bf36b78b55d0dd6e19387dcf5ce7f /app-misc/rlwrap/rlwrap-0.45.2-r1.ebuild
parentdev-lisp/asdf: update EAPI 6 -> 7 (diff)
downloadgentoo-e1f7fc1b141be3d636b4c7d3fef203cc0bc96dea.tar.gz
gentoo-e1f7fc1b141be3d636b4c7d3fef203cc0bc96dea.tar.bz2
gentoo-e1f7fc1b141be3d636b4c7d3fef203cc0bc96dea.zip
app-misc/rlwrap: use autotools.eclass, not manual autoreconf
Vanilla autoreconf won't benefit from error handling or the other magic the eclass does for us. Also add a missing ncurses dependency. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-misc/rlwrap/rlwrap-0.45.2-r1.ebuild')
-rw-r--r--app-misc/rlwrap/rlwrap-0.45.2-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-misc/rlwrap/rlwrap-0.45.2-r1.ebuild b/app-misc/rlwrap/rlwrap-0.45.2-r1.ebuild
new file mode 100644
index 000000000000..c981173038ec
--- /dev/null
+++ b/app-misc/rlwrap/rlwrap-0.45.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="GNU readline wrapper"
+HOMEPAGE="https://github.com/hanslub42/rlwrap"
+SRC_URI="https://github.com/hanslub42/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~mips ~ppc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="debug"
+
+RDEPEND="sys-libs/ncurses:=
+ sys-libs/readline:="
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable debug)
+}