summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/rlwrap/rlwrap-0.45.2-r1.ebuild')
-rw-r--r--app-misc/rlwrap/rlwrap-0.45.2-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-misc/rlwrap/rlwrap-0.45.2-r1.ebuild b/app-misc/rlwrap/rlwrap-0.45.2-r1.ebuild
new file mode 100644
index 000000000000..c981173038ec
--- /dev/null
+++ b/app-misc/rlwrap/rlwrap-0.45.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="GNU readline wrapper"
+HOMEPAGE="https://github.com/hanslub42/rlwrap"
+SRC_URI="https://github.com/hanslub42/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~mips ~ppc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="debug"
+
+RDEPEND="sys-libs/ncurses:=
+ sys-libs/readline:="
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable debug)
+}