summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-12 20:01:49 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-12 20:01:49 +0200
commit0d921fb9c272d16408469d503a60a7a719bcab98 (patch)
treeebcca4a5d27c05cb822daa5cf17d1f7fcd57ad3a /app-misc/votrify/votrify-5.ebuild
parentapp-misc/votrify: Bump to v4 (diff)
downloadgentoo-0d921fb9c272d16408469d503a60a7a719bcab98.tar.gz
gentoo-0d921fb9c272d16408469d503a60a7a719bcab98.tar.bz2
gentoo-0d921fb9c272d16408469d503a60a7a719bcab98.zip
app-misc/votrify: Bump to v5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-misc/votrify/votrify-5.ebuild')
-rw-r--r--app-misc/votrify/votrify-5.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-misc/votrify/votrify-5.ebuild b/app-misc/votrify/votrify-5.ebuild
new file mode 100644
index 000000000000..278667874da3
--- /dev/null
+++ b/app-misc/votrify/votrify-5.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit python-single-r1
+
+DESCRIPTION="Tool for community verification of Gentoo elections"
+HOMEPAGE="https://github.com/mgorny/votrify"
+SRC_URI="https://github.com/mgorny/votrify/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-misc/gentoo-elections"
+
+src_configure() {
+ # update default location for election scripts
+ sed -i -e "s^os.path.dirname(__file__)^'${EPREFIX}/usr/lib'^" \
+ votrify-make-confirmation || die
+
+ python_fix_shebang votrify-{make,verify}-*
+}
+
+make_wrappers() {
+ local election=${1}
+
+ newbin - "votrify-${election}-make" \
+ < <(sed -e "s^@ELECTION@^${election}^" \
+ votrify-wrapper-make.bash.in || die)
+ newbin - "votrify-${election}-verify" \
+ < <(sed -e "s^@ELECTION@^${election}^" \
+ votrify-wrapper-verify.bash.in || die)
+}
+
+src_install() {
+ dobin votrify-{make,verify}-*
+ make_wrappers council-201906
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "In order to interactively create confirmation for Council 2019 election:"
+ elog " votrify-council-201906-make"
+ elog
+ elog "In order to verify the results for Council 2019 election:"
+ elog " votrify-council-201906-verify"
+}