summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-05-04 21:45:54 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-05-04 21:50:59 +0300
commitfaeb435554d40b21905ef52b00ed317697c70c3b (patch)
tree1410e2336a20abbd8906c8cad1f8d94ffea1c0ae /app-misc/ytree/ytree-2.08.ebuild
parentapp-misc/ytree: drop 2.02, 2.04 (diff)
downloadgentoo-faeb435554d40b21905ef52b00ed317697c70c3b.tar.gz
gentoo-faeb435554d40b21905ef52b00ed317697c70c3b.tar.bz2
gentoo-faeb435554d40b21905ef52b00ed317697c70c3b.zip
app-misc/ytree: add 2.08
This version has fixed build on musl (tested on musl container from stage3). Closes: https://bugs.gentoo.org/714200 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-misc/ytree/ytree-2.08.ebuild')
-rw-r--r--app-misc/ytree/ytree-2.08.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-misc/ytree/ytree-2.08.ebuild b/app-misc/ytree/ytree-2.08.ebuild
new file mode 100644
index 000000000000..22e983bf444f
--- /dev/null
+++ b/app-misc/ytree/ytree-2.08.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A curses-based file manager"
+HOMEPAGE="https://www.han.de/~werner/ytree.html"
+SRC_URI="https://www.han.de/~werner/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+DEPEND="
+ sys-libs/ncurses:0=
+ sys-libs/readline:0=
+"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( CHANGES README THANKS ytree.conf )
+
+src_configure() {
+ tc-export CC PKG_CONFIG
+
+ default
+}
+
+src_install() {
+ einstalldocs
+ dobin ${PN}
+ doman ${PN}.1
+}