summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/ytree/ytree-2.08.ebuild')
-rw-r--r--app-misc/ytree/ytree-2.08.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-misc/ytree/ytree-2.08.ebuild b/app-misc/ytree/ytree-2.08.ebuild
new file mode 100644
index 000000000000..22e983bf444f
--- /dev/null
+++ b/app-misc/ytree/ytree-2.08.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A curses-based file manager"
+HOMEPAGE="https://www.han.de/~werner/ytree.html"
+SRC_URI="https://www.han.de/~werner/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+DEPEND="
+ sys-libs/ncurses:0=
+ sys-libs/readline:0=
+"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( CHANGES README THANKS ytree.conf )
+
+src_configure() {
+ tc-export CC PKG_CONFIG
+
+ default
+}
+
+src_install() {
+ einstalldocs
+ dobin ${PN}
+ doman ${PN}.1
+}