summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-05-21 16:48:20 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-05-21 16:50:22 +0200
commit78e5e3edf06b85fbe02628e6b8b1dc943aeea138 (patch)
treeb60a2fe46f0c6c06690e6ee086a09fad078e3d90 /app-portage/elicense/elicense-9999.ebuild
parentnet-dns/pdns-recursor: Version bump (diff)
downloadgentoo-78e5e3edf06b85fbe02628e6b8b1dc943aeea138.tar.gz
gentoo-78e5e3edf06b85fbe02628e6b8b1dc943aeea138.tar.bz2
gentoo-78e5e3edf06b85fbe02628e6b8b1dc943aeea138.zip
app-portage/elicense: update live ebuild
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'app-portage/elicense/elicense-9999.ebuild')
-rw-r--r--app-portage/elicense/elicense-9999.ebuild13
1 files changed, 13 insertions, 0 deletions
diff --git a/app-portage/elicense/elicense-9999.ebuild b/app-portage/elicense/elicense-9999.ebuild
index a7cb3da3c328..bbba9eea7ef6 100644
--- a/app-portage/elicense/elicense-9999.ebuild
+++ b/app-portage/elicense/elicense-9999.ebuild
@@ -21,3 +21,16 @@ SLOT="0"
IUSE=""
RDEPEND=">=sys-apps/portage-2.3.62[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ default
+
+ local MY_PV=${PV}
+ if [[ ${PV} == "9999" ]]; then
+ local last_commit=$(git rev-parse HEAD)
+ MY_PV="${last_commit:0:7}-git"
+ fi
+
+ sed -i -e "s/^MY_PV =.*$/MY_PV = \"${MY_PV}\"/" \
+ elicense || die "Failed to sed in version."
+}