summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-08-30 12:22:55 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-08-30 12:42:02 -0400
commit39e03b007525ff9c271b8bf2be84b4a3fe417a1c (patch)
treeac25dd1d7eeb91b131e9421fb0b9b8e7365e0b61 /app-portage/iwdevtools
parentsys-firmware/intel-microcode: bump (diff)
downloadgentoo-39e03b007525ff9c271b8bf2be84b4a3fe417a1c.tar.gz
gentoo-39e03b007525ff9c271b8bf2be84b4a3fe417a1c.tar.bz2
gentoo-39e03b007525ff9c271b8bf2be84b4a3fe417a1c.zip
app-portage/iwdevtools: prefix support, fix symlink, no abigail
This ../../../ thankfully worked on non-prefix, but one .. too many. Remove abigail from test deps as the test is too specific and will typically be skipped. This -Deprefix is not to be confused with --prefix which is still ${EPREFIX}/usr, intended to be exactly ${EPREFIX} and not used for installation paths. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-portage/iwdevtools')
-rw-r--r--app-portage/iwdevtools/iwdevtools-0.3.1.ebuild2
-rw-r--r--app-portage/iwdevtools/iwdevtools-0.4.0.ebuild2
-rw-r--r--app-portage/iwdevtools/iwdevtools-9999.ebuild15
3 files changed, 10 insertions, 9 deletions
diff --git a/app-portage/iwdevtools/iwdevtools-0.3.1.ebuild b/app-portage/iwdevtools/iwdevtools-0.3.1.ebuild
index 7637b8439253..a4a8c6a5377a 100644
--- a/app-portage/iwdevtools/iwdevtools-0.3.1.ebuild
+++ b/app-portage/iwdevtools/iwdevtools-0.3.1.ebuild
@@ -33,7 +33,7 @@ pkg_postinst() {
elog "at ${EROOT}/usr/share/${PN}. If not already using a bashrc, you can use"
elog "the example bashrc directly by creating a symlink:"
elog
- elog " ln -s ../../../usr/share/${PN}/bashrc ${EROOT}/etc/portage/bashrc"
+ elog " ln -s ../../usr/share/${PN}/bashrc ${EROOT}/etc/portage/bashrc"
elog
elog "See ${EROOT}/usr/share/doc/${PF}/README.rst* for info on tools."
fi
diff --git a/app-portage/iwdevtools/iwdevtools-0.4.0.ebuild b/app-portage/iwdevtools/iwdevtools-0.4.0.ebuild
index c8f5f248d61c..1152e307b338 100644
--- a/app-portage/iwdevtools/iwdevtools-0.4.0.ebuild
+++ b/app-portage/iwdevtools/iwdevtools-0.4.0.ebuild
@@ -36,7 +36,7 @@ pkg_postinst() {
elog "at ${EROOT}/usr/share/${PN}. If not already using a bashrc, you can use"
elog "the example bashrc directly by creating a symlink:"
elog
- elog " ln -s ../../../usr/share/${PN}/bashrc ${EROOT}/etc/portage/bashrc"
+ elog " ln -s ../../usr/share/${PN}/bashrc ${EROOT}/etc/portage/bashrc"
elog
elog "See ${EROOT}/usr/share/doc/${PF}/README.rst* for info on tools."
fi
diff --git a/app-portage/iwdevtools/iwdevtools-9999.ebuild b/app-portage/iwdevtools/iwdevtools-9999.ebuild
index 9352ae24fd78..0af26d4a3147 100644
--- a/app-portage/iwdevtools/iwdevtools-9999.ebuild
+++ b/app-portage/iwdevtools/iwdevtools-9999.ebuild
@@ -22,14 +22,15 @@ RDEPEND="
sys-apps/file
sys-apps/portage
sys-apps/util-linux"
-BDEPEND="
- test? (
- ${RDEPEND}
- dev-util/libabigail
- )"
+BDEPEND="test? ( ${RDEPEND} )"
src_configure() {
- meson_src_configure -Ddocdir=${PF} $(meson_use test)
+ local emesonargs=(
+ -Ddocdir=${PF}
+ -Deprefix="${EPREFIX}"
+ $(meson_use test)
+ )
+ meson_src_configure
}
pkg_postinst() {
@@ -40,7 +41,7 @@ pkg_postinst() {
elog "at ${EROOT}/usr/share/${PN}. If not already using a bashrc, you can use"
elog "the example bashrc directly by creating a symlink:"
elog
- elog " ln -s ../../../usr/share/${PN}/bashrc ${EROOT}/etc/portage/bashrc"
+ elog " ln -s ../../usr/share/${PN}/bashrc ${EROOT}/etc/portage/bashrc"
elog
elog "See ${EROOT}/usr/share/doc/${PF}/README.rst* for info on tools."
fi