summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2020-03-10 16:43:30 +0100
committerPatrice Clement <monsieurp@gentoo.org>2020-03-10 16:45:17 +0100
commit748250033d52ef9a8ea16d1b7914a2b3086c4a5f (patch)
treed98f1e78d3d3eae2368a2cd07a20a0d8059aa13f /app-shells/hstr/hstr-2.1.ebuild
parentdev-python/httpretty: Bump to 0.9.7 (diff)
downloadgentoo-748250033d52ef9a8ea16d1b7914a2b3086c4a5f.tar.gz
gentoo-748250033d52ef9a8ea16d1b7914a2b3086c4a5f.tar.bz2
gentoo-748250033d52ef9a8ea16d1b7914a2b3086c4a5f.zip
app-shells/hstr: version bump.
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-shells/hstr/hstr-2.1.ebuild')
-rw-r--r--app-shells/hstr/hstr-2.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-shells/hstr/hstr-2.1.ebuild b/app-shells/hstr/hstr-2.1.ebuild
new file mode 100644
index 000000000000..f9bffba4e61d
--- /dev/null
+++ b/app-shells/hstr/hstr-2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Shell history suggest box"
+HOMEPAGE="https://github.com/dvorka/hstr http://www.mindforger.com"
+SRC_URI="https://github.com/dvorka/hstr/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ sys-libs/ncurses:0=[unicode]"
+
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( CONFIGURATION.md README.md )
+
+PATCHES=( ${FILESDIR}/${P}-fix-ncurses-configure.patch )
+
+src_prepare() {
+ default
+ sed \
+ -e 's:-O2::g' \
+ -i src/Makefile.am || die
+ eautoreconf
+}