summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-12-08 23:46:55 +0100
committerPatrice Clement <monsieurp@gentoo.org>2016-12-08 23:47:50 +0100
commit8895d3bdc452f367b2b02a4d243d10f8226a0661 (patch)
tree641358c713c8efebd76a228feb2b072d808b3282 /app-shells
parentapp-shells/scsh: EAPI 6 bump and clean up. (diff)
downloadgentoo-8895d3bdc452f367b2b02a4d243d10f8226a0661.tar.gz
gentoo-8895d3bdc452f367b2b02a4d243d10f8226a0661.tar.bz2
gentoo-8895d3bdc452f367b2b02a4d243d10f8226a0661.zip
app-shells/scsh-install-lib: EAPI 6 bump.
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/scsh-install-lib/scsh-install-lib-1.3.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-shells/scsh-install-lib/scsh-install-lib-1.3.0-r1.ebuild b/app-shells/scsh-install-lib/scsh-install-lib-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..e63d9ab66aa5
--- /dev/null
+++ b/app-shells/scsh-install-lib/scsh-install-lib-1.3.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit scsh
+
+DESCRIPTION="Installation tool for the Scheme Untergrund Library"
+HOMEPAGE="http://lamp.epfl.ch/~schinz/scsh_packages/"
+SRC_URI="http://lamp.epfl.ch/~schinz/scsh_packages/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=app-shells/scsh-0.6.6"
+
+src_prepare() {
+ default
+}
+
+src_install() {
+ dodir "${SCSH_MODULES_PATH}"
+ ./install.scm ${SCSH_LAYOUT_CONF} \
+ --bindir /usr/bin \
+ --force \
+ || die "./install.scm failed"
+}