summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2021-09-27 22:25:50 +0300
committerIonen Wolkens <ionen@gentoo.org>2021-09-28 20:56:35 -0400
commitef42a7f69b0f13c7c03f737a7ba6212201c25ee5 (patch)
treed16068c5f35725dd5406fc8f3142ac842f2c0be0 /app-text/cmark/cmark-0.30.2.ebuild
parentapp-editors/kakoune: Drop old release. (diff)
downloadgentoo-ef42a7f69b0f13c7c03f737a7ba6212201c25ee5.tar.gz
gentoo-ef42a7f69b0f13c7c03f737a7ba6212201c25ee5.tar.bz2
gentoo-ef42a7f69b0f13c7c03f737a7ba6212201c25ee5.zip
app-text/cmark: update to 0.30.2
Updated to EAPI=8. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-text/cmark/cmark-0.30.2.ebuild')
-rw-r--r--app-text/cmark/cmark-0.30.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-text/cmark/cmark-0.30.2.ebuild b/app-text/cmark/cmark-0.30.2.ebuild
new file mode 100644
index 000000000000..67faa19c8c54
--- /dev/null
+++ b/app-text/cmark/cmark-0.30.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit cmake python-any-r1
+
+DESCRIPTION="CommonMark parsing and rendering library and program in C"
+HOMEPAGE="https://github.com/commonmark/cmark"
+SRC_URI="https://github.com/commonmark/cmark/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( ${PYTHON_DEPS} )"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMARK_LIB_FUZZER=OFF
+ -DCMARK_SHARED=ON
+ -DCMARK_STATIC=OFF
+ -DCMARK_TESTS="$(usex test)"
+ )
+ cmake_src_configure
+}