summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/expander/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/expander/files')
-rw-r--r--app-text/expander/files/expander-2.0.5-gentoo.patch58
1 files changed, 58 insertions, 0 deletions
diff --git a/app-text/expander/files/expander-2.0.5-gentoo.patch b/app-text/expander/files/expander-2.0.5-gentoo.patch
new file mode 100644
index 000000000000..460a8164cee5
--- /dev/null
+++ b/app-text/expander/files/expander-2.0.5-gentoo.patch
@@ -0,0 +1,58 @@
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -3,15 +3,14 @@
+ bindir = $(BINDIR)/
+
+ copy = ln -fs
+-CFLAGS += -v -g # -DNEED_GETOPT_PROTO_TYPE
+-compiler = cc $(CFLAGS)
++compiler = $(CC) $(CFLAGS)
+
+ executables = expander boxcomment align_columns align_comments where_is
+
+ #--------------
+ # Build Targets
+ #--------------
+-all: verify $(executables)
++all: $(executables)
+
+ verify:
+ @if [ "$(bindir)" = "/" ]; then \
+@@ -24,32 +23,31 @@
+ # Abbreviation expansion filter program (with NEdit, language sensitive)
+ #-----------------------------------------------------------------------
+ expander: expander.c
+- $(compiler) -o $(bindir)$@ $?
++ $(compiler) $(LDFLAGS) -o $@ $?
+
+ #--------------------------------------------------------------------------
+ # Surround given text with open ended box. (with NEdit, language sensitive)
+ #--------------------------------------------------------------------------
+ boxcomment: boxcomment.c
+- $(compiler) -o $(bindir)$@ $?
+- @if [ ! -f $(bindir)un$@ ]; then $(copy) $(bindir)$@ $(bindir)un$@; fi
++ $(compiler) $(LDFLAGS) -o $@ $?
+
+ #-------------------------------------------------------------------------------
+ # Align ragged looking 'C' style comments (good substitute for align_equals too)
+ #-------------------------------------------------------------------------------
+ align_comments: align_comments.c
+- $(compiler) -o $(bindir)$@ $?
++ $(compiler) $(LDFLAGS) -o $@ $?
+
+ #----------------------------
+ # Align given text in columns
+ #----------------------------
+ align_columns: align_columns.c
+- $(compiler) -o $(bindir)$@ $?
++ $(compiler) $(LDFLAGS) -o $@ $?
+
+ #----------------------------------------------
+ # File locator (substitute for which, where...)
+ #----------------------------------------------
+ where_is: where_is.c
+- $(compiler) -o $(bindir)$@ $?
++ $(compiler) $(LDFLAGS) -o $@ $?
+
+ #------------------------------------------------
+ # Here is how to uninstall the executables built.