summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2017-01-03 12:15:18 -0500
committerBrian Evans <grknight@gentoo.org>2017-01-04 09:53:00 -0500
commit5357a645501ecd21d14f40306bd3efe231bf0165 (patch)
treec847b1ef2dbc30676424aede46435a4dff70e47a /app-text/groonga-normalizer-mysql/groonga-normalizer-mysql-1.1.1.ebuild
parentdev-python/pygpu: remove doc building, not ready yet (diff)
downloadgentoo-5357a645501ecd21d14f40306bd3efe231bf0165.tar.gz
gentoo-5357a645501ecd21d14f40306bd3efe231bf0165.tar.bz2
gentoo-5357a645501ecd21d14f40306bd3efe231bf0165.zip
app-text/groonga-normalizer-mysql: Version bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-text/groonga-normalizer-mysql/groonga-normalizer-mysql-1.1.1.ebuild')
-rw-r--r--app-text/groonga-normalizer-mysql/groonga-normalizer-mysql-1.1.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-text/groonga-normalizer-mysql/groonga-normalizer-mysql-1.1.1.ebuild b/app-text/groonga-normalizer-mysql/groonga-normalizer-mysql-1.1.1.ebuild
new file mode 100644
index 000000000000..7d5abb8b4112
--- /dev/null
+++ b/app-text/groonga-normalizer-mysql/groonga-normalizer-mysql-1.1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils autotools
+
+DESCRIPTION="Groonga plugin that provides MySQL compatible normalizers"
+HOMEPAGE="http://groonga.org/"
+SRC_URI="http://packages.groonga.org/source/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-text/groonga"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+DOCS=( README.md )
+
+src_prepare() {
+ default_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ # ruby is only uses for tests
+ econf \
+ --without-ruby \
+ --docdir="${EROOT}usr/share/doc/${P}"
+}
+
+src_install() {
+ default
+
+ prune_libtool_files
+ rm -r "${D}usr/share/doc/${PN}" || die
+}